PreSonus FaderPort 2 (2018) midi remote script

I’m not experiencing this behavior

Hey good news. I solved this behaviour by deselecting “Sync Selection in Project Window and Mixconsole” in the preferences. :ok_hand:t2:

The only thing I can’t solve is - opening or closing a plugin window still stops playback. But at least now i can navigate and make fader adjustments

edit: my mistake. This didn’t work. They need to be linked

hello Werner,

Firstly - thank you, thank you, thank you! The script is great and I use it all the time however…

I have a strange issue that I haven’t been able to resolve.

When I open a project that uses the script - sometimes, not always, the script stops working and the only way I can get it working again is to switch the faderport off, wait for the track assignments (the white highlighting under the track that it was actively assigned to) then turn it on again and wait for the track highlighting to turn back on again, then, repeat these actions, i.e. turn the faderport on/off twice!!!

It’s not logical as to why I have to do it twice.

I have been using the script with the faderport for 2 months now and hoped that I might spot some common practice that might be triggering the loss of connection but haven’t seen it and can only recreate the loss if I leave the device idle for sometime - even then that doesn’t always cause the issue!

I know this is a random problem and as such hard to resolve and it is only slightly frustrating as once the off/on, off/on strategy has been done it seems far more stable even when changing projects.

Just wondering if you, as a far more knowledgeable person than I, may have an insight or suggestion as to what is causing this issue.

I am using the latest javascript version of your script with Cubase 12 Pro 12.0.52 on Windows 10 64 bit

Any thoughts?
Thanks in advance

It sounds like the same problem that davisda1 described and that I also have. It seems to be totally random, but try to disable the script for the faderport and then reenable it. That works for me anyway. It’s a bit of a hassle but it’s better than turning it off and on twice.

hi thanks for the response.
Yeah sometimes that works but not always - and sometimes I have to do both!!!
Interesting that its not just a problem for me - do you have another controller connected as well? I have a piano keyboard with some pads and knobs connected. I don’t use them but wondered if that might be why but I have found that even if I’m not playing it the faderport will drop .


Yes. I have three other controllers connected. One synth, a stream deck and a Korg nanokontrol studio. So far I have not been able to see any pattern to when the Faderport loses connection.


it is very difficult for me to search for such an issue, because I did not observe this on my system until now.
At the start of development I had from time to time this kind of issues and found out, that it’s connected to setting colors for button. By removing this lines it was gone. May this is happening again? May dependent do some specific settings?
But this is the only thing I have in mind at this moment.

Would any of you be willing to show me his system/project/configuration in a Teams session? Maybe I see there some start points for new investigations.


We can do a teams session if that can help you solve the mystery. I am available today.

Hi there, I had an interesting experiance: for a long time I had the problem that the script cilled the start and also the shut down of CB, it allways hung up during initialization of the controlls. I now solved this prob by removing the settings folder to reset all program settings. I think the main problem comes from settings kept from older CB versions, especially when you use CB for many years now like me.

Thank you for your reply. I too am happy to let you see my system but I have not got MS Teams but I do have What’s App which we could do a video call with so you could see the Faderport too?

And in response to the other post, I have been using Cubase since Cubase SX so I may well have “remnants” of settings from previous versions. So it may be a commonality that gives a clue.

Thanks to everyone for you time in offering support for this issue.


Hello all,

I had a session with @hegerber yesterday evening. @hegerber tested also a small change in the script, that deactivates the color setting for the buttons (the button color will then stick to stock setting). According his feedback this worked for him.
Maybe this is an issue with a specific driver version or firmware FaderPort, maybe also related to the OS (Win10/Win11, MacOs on intel/M).

@Robin_S, could please do the test also on your system. This is a small test version with removed lines… (9.8 KB)

The idea to reset the settings is very good, too.

I got some new ideas to test/reproduce the issue yesterdays session. I keep you up to date on this.


1 Like

Thank you again Werner,
I have just finished work so will have a go tonight with the test script and let you know how it goes.

Incidentally, is the ‘settings’ folder that could be removed the one in the midi remote folder? i.e. C:\Users\User\Documents\Steinberg\Cubase\MIDI Remote*User Settings* or is it another folder altogether?

Thank you again

The modified test script seemed to work better for me, but unfortunately I am afraid it has not removed the problem. It works better now, but the problem has returned at least one time.


I’m whispering this … I don’t want to tempt fate but … I think, just maybe, perhaps its solved the issue for me!

I used it for a couple of hours last night with only one drop out (possibly my fault as it was inactive for a while when I answered an email)and then today it has worked without drop out for several hours!

If I load a composition I did a few weeks ago I do have to disable the script, refresh it and then enable again but after that, perfect!
The only visible difference is that the PAN and CHANNEL buttons are now illuminated ‘white’ instead of ‘blue’ which I actually prefer.

So, Werner I think I should be buying you several ‘cups of coffee’ as this script is now working exactly as described on my machine. I didn’t have to do anything else but replace the previous one in the C:\Users\Username\Documents\Steinberg\Cubase\MIDI Remote\Driver Scripts\Local\PreSonus\FaderPort folder.

Thank you for all your time and efforts and responding so promptly to OP - it is sincerely appreciated.


1 Like

Hey all, sorry for the naivety but I am painfully brand new to javascripts and installing new remotes n’ such… I just got the Faderport V2 and got it to work with my Cubase 9 Pro, but would love to have the fader work on any selected track (not within a batch.) So I downloaded Werner’s newest javascript and the midiremote file but have no clue where to copy these files to, as the directions included indicate that I’m to put the java in C:\Users\USERNAME\Documents\Steinberg\Cubase\MIDI Remote\Driver Scripts\Local\PreSonus\FaderPort but on my system (Windows 10) no such address exists. No folders beyond that Cubase folder in the path, so there are no " MIDI remote" or “Driver Scripts” folders in that path. Am I to simply create/add new folders to then make the extended path \MIDI Remote\Driver Scripts\Local\PreSonus\FaderPort ??
Also, the directions say to load the PreSonus_FaderPort.midiremote file by using the MIDI Remote Manger and clicking the “add surface” button, but of course, Cubase 9 has no “Midi Remote Manger” with an add surface button. But it does have a MIDI Device Manager with buttons to “install device” or “open device.” No clue how to go about this!

Sorry again for the derailing, and thanks a million to anyone who can help my technologically deficient self!!


Hello @KSutt,

I have to disappoint you unfortunately. The MIDI Remote API and possibilities were introduced in Cubase 12. This means, that the script will work only with Cubase 12.


Thanks for the response Werner! Much appreciated

Unfortunately still getting issue with master volume and other buttons related to rotary controller.

Currently in one project the only buttons connected with the rotary controller that functions are “LINK” and “CLICK”
So no control of “PAN”, “MASTER” etc.
All other non rotary buttons are functioning.

Another thought. I have a Stream Deck and have configured a fader for “CLICK”. It would be a vast improvement for the Faderport Rotary to set this value. Perhaps with “SHIFT” and “CLICK” leaving the non “SHIFT” click to switch on and off.

Discovered if I revert to a “bak” of the same project all is OK. So something I did broke the connection.

Also note if I load this" bak" directly after closing the non working “cpr” it also does not function correctly, however if I close and reopen Cubase then the “bak” functions correctly.

Hope this is of some help.

Has anyone tried to run or adapt this script to work with FaderPort Classic (V1)?