Problem after updating Dorico 5

Good evening,
I just updated to Dorico 5 and the Time Signatures and Notes look this way:

Why does this occur? How can I return to the previous “layout”?

Thank you.

Have you restarted after updating?

1 Like

Yes, of course!
And I am not able to run Dorico if I do not work with Terminal (in Mac) as it is stated in this post:

In addittion, NotePerformer does not work with Dorico! I wish I never updated to Dorico 5…!

1 Like

A large number of users have no problem using Dorico and using it with NP, so IMO your willingness to give up on the program is premature.

You only posted your first post of this thread two hours ago; if you show a little patience, Daniel or Ulf or Richard will likely show up before long to offer assistance from the Dorico Team.

Dan’s suggestion to restart the computer after updating the program is a standard piece of wise advice, particularly if the fonts seem to be askew.

4 Likes

Yes, I know! Thank you for your message. I was a little bit desperated because I have to do a job and I have really little time, and when I downloaded Dorico 5, it was not working and it crashed Dorico 4 too, so I was unable to work!

Now I can run Dorico 4, at least, and we’ll see what happens with Dorico 5…

Hi @gualgasull , is the layout problem now the only issue that you have with Dorico 5?
And could you please do in Dorico 5 from the menu Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

As of Dorico 5 it is in theory no longer necessary to restart after installing new versions of the fonts, but in fact I don’t think Bravura or Petaluma changed between the last release of Dorico 4 and Dorico 5 in any case.

Dorico 5 is built upon a new version of Qt, and one of the problems that this has brought is that there is a change (we think an unintentional one) in font glyph measurement, which causes e.g. some time signature digits to be positioned wrongly vertically (discussed e.g. here). We’ve not seen this affect horizontal placement of stems etc., but I think it’s quite plausible that it might.

@gualgasull, what resolution is your display running at? Is it 1920x1080 or something similar?

No, as I stated yesterday, I can only run Dorico 5 if I work with the Terminal (as it says in the post I linked) every time I want to run the program.
NotePerformer 4 (updated yesterday and running correctly with Dorico 4) does not work with Dorico 5 and the layout problems continue.

I attach the Diagnostics report zip.
Dorico Diagnostics.zip (2.2 MB)

Moreover, I cannot run Dorico 4 due to the VST Audio Engine problem. When I stop it in the Activity Monitor, then I can run Dorico 4; but I have to do this every time I have run (or tried it…) Dorico 5 before.

Now I am working with a MacBook Pro Retina 13-inch and the layout is appearing this way:

The noteheads and stems appear to be correctly displayed, but I think that the time signature is not displaying well.

Yesterday I was working with an external screen which is 2560x1440, but today I am not at home and I cannot check it back.

Thank you for your help! I hope all the problems will be solved…!

Right, I think the display problem you’re experiencing is absolutely the font measurement issue that I mentioned in my previous reply. That will be fixed in the next update.

It sounds like the problem you’re having with being unable to run both Dorico 4 and Dorico 5 is going to be that the audio engine is hanging around. After you quit either Dorico 4 or Dorico 5, run Activity Monitor and look for a process in the list called “VST Audio Engine”. If you see it there, select it, and click the “X” button in the toolbar to quit the process. Then start Dorico again, and it should start up with no problems.

You can’t run both Dorico 4 and Dorico 5 simultaneously.

I have experienced this before, and you may find that re-selecting the Music font in Library > Music Fonts will fix it, for each document.

The cause is likely something in your userlibrary.xml file, so you might want to consider trashing it, and then re-configuring the various settings, like Paragraph Styles, Font Styles, etc.

A bit of a pain, but it’s better in the long run.

Thank you for the reply! Yes, I read about this in another post (Activity Monitor and quitting de VST Audio Engine).

The issue is that I cannot run Dorico 5 normally, I always have to do it pasting this text in the Terminal:

env QSG_RHI_BACKEND="opengl" /Applications/Dorico\ 5.app/Contents/MacOS/Dorico\ 5

I obviously can do it, but it is a little tedious having to do it every time I want to run the program.

And the other question that is still unsolved: why I cannot use NotePerformer 4 in Dorico 5? What am I doing wrong?

Thank you.

You have to use that Terminal command because your Mac uses an old Intel graphics adaptor with a bug in its Metal drivers. We will introduce a workaround for this driver bug in the next update that means you will no longer need to use this Terminal command.

Regarding your NotePerformer problem, as far as I can tell, the NotePerformer plug-in is being detected by Dorico with no problems. What happens when you try to apply the NotePerformer playback template via Play > Playback Template?

1 Like

I had a look again at your diagnostics, and NotePerforrmer does get loaded with you, but all your channels in the Dorico mixer are pulled down to gain zero, that’s why you don’t hear anything. Press F3 to open the Dorico mixer and there you can adjust the channel levels.

1 Like

Probably you should go to the Play page of Preferences and adjust the default Mixer gain there. When you then re-apply the playback template in your projects, the default gain value will be applied.

1 Like

Good morning!
I tried all the things that you told me regarding NotePerformer (applying it via Play > Playback Template, readjusting the gain in Mixer…) and it continues not to work.

In addittion, just in case it helps you, there is also a problem with the brackets and lines appearance:

When I click on “Reset to factory” on Engraving options, it shows like this:

which I am afraid that it is not the “correct” way indeed…

Will this be fixed in the next update too? It is a little embarrassing having to reset to factory for every single project…

Thank you!

What would be the “correct” way?

That suggests that you have saved your default Engraving Options to something ‘non-standard’.

This is not a fix for the developers. You will need to correct the Engraving Options, and then Save As Defaults.

As far as I can tell, the ‘factory’ brackets are correct for strings and piano.

1 Like

Good afternoon,
As I stated some days ago, NotePerformer 4 is not running with Dorico 5.

On the other post, the developers told me that my gains were adjusted to 0, but having them at their default levels does not work indeed.

I attach a screenshot of the mixer and the Diagnostic Report, just in case it can help to solve my problem.

Thank you!

Captura de Pantalla 2023-07-04 a les 13.20.37

Dorico Diagnostics.zip (523.4 KB)

Thanks for the data. This is really strange, in the moment you took the diagnostics you had a project open and the model data says that again all the fader are pulled down to minus infinity, yet again, your screenshot says something different.
What if you move every fader just a little bit? Does suddenly sound come out? Please also create a new report again at that moment, because I want to see the model data again.