Rolling back to 13.0.30 - need installer

Have you reread yourself, before posting ? :roll_eyes:

Seriously, what do you think you are bringing to all of us, with this tirade ? What’s the aim ?

Isn’t that jumping the gun a bit? The update has been out for less than 36 hours.

What can I say? I have used it for around 5 hours yesterday and another 4 today.

So 9 hours of use and already deemed the most stable version in over 30 years. Amazing!

1 Like

Have you had a look in your downloads folder?

C:\Users\your username\Downloads\Steinberg\WIN64

Agreed, it’s also odd because for v12 and earlier, you can see the various updates available, v12 from the link below, scroll down to the bottom:

This should be available for the latest version of Cubase too, thinking it’s some sort of a coding error. I also had a look at the Steinberg FTP, could not see v6…5 and above.

Sorry, but that is fundamentally untrue. See Post Office…

But I would agree with some of what you say. I like this version of Cubase, I think it’s the best yet and some of the new features, such as in-phase warping of multiple channels, are a lifesaver and a work of genius.

I was a bit taken aback by the new interface at first but I’ve got used to it and have spoken up in its favour elsewhere, and will continue to sing its praises where deserved. But I will continue to be critical of basic errors and omissions as we should all do. That’s how wrinkles get ironed out.

It’s true, I am!


Hi Martin, thanks for that. I have posted about my issues on my own and on another thread as well.

One of the dealbreakers for me still:


Anyone here have version 13.0.30 (Elements) for Windows ?
Thought I still had it, but nope. Thanks in advance.
Mixer is slow for me with latest update.

Thanks a lot! I’m rolling back as well. :slight_smile:

does anyone know how to get back to 13.0.30 for the MAC ?

I found that the control room correct software keeps turning on and off from the vst slot. Might be Dirac Live but I do not remember this happening with 13.0.30 but I need to roll back to test this.

Do I need to uninstall cubase completely to roll back on the MAC ?

Are you talking about 11.0.30 or 13.0.30? You will see a link for 13.0.30 in this very topic.


Typo, thanks for spotting that. I have worked it out today and rolled back.

On Mac right clicked Cubase 13 in Applications and move to the bin and then installed 13.0.30. It kept all my settings but I did save my key commands first.

It does seem to be a control room plugin issue but I cannot say for sure it’s 13.0.40. It could be DiracLive does not like that version or my touch screen software, which I know messes with DiracLive when creating a room calibration but not when used in my DAW, is causing the issue.

But updated touch screen software and tested with 13.0.30 today and the control room, with DiracLive, worked perfectly.

——update—- it just did it again :frowning: so not connected to 13.0.40 but it could be the new reverb from Spitfire Audio. It seems to happen when i send to that.