Sharing a workaround: Found a way to write polyrhythms with the proper time signature displaying.

I found a way to write polyrhythms that have the same bar length and display the proper time signature. I’m sure this will be done natively in the fullness of time, but for now, this a pretty good workaround. Here’s what it looks like in Bach’s “Jesus bleibet meine Freude”:


Normally, this is easy to do using triplets and hiding the numbers and brackets (which is faster to do now that there is a filter), but the time signature would remain 3/4. To get the 9/8 follow this procedure:

  1. Select the bar you want to modify on the chosen instrument (in this case: the first bar of Vln I)
  2. Enter shift/M and type: 9/8,6 (it’s a pickup – it has to have the same number of values as the meter of the other instruments, in this case: six 8th notes)
  3. Type alt-enter to activate it on the bar alone. The first barlines should align but the others will not.
  4. Fix the alignment by selecting the 2nd bar (on the same instrument), typing shift-M, entering 3/4 and then alt-enter.
  5. This screws up the bar numbering on that part. Go to the appropriate part layout, select the 2nd bar, change the bar number to 2, then go back to the full score to hide both the 3/4 time signature and the bar number change using the properties panel.
  6. Write a tuplet of 6:9 ration in the first bar of the selected instruments. Enter music and re-beam. Enter the rest of the music as triplets and get rid of the brackets and numbers.

Note that you can do that anywhere in a score, not just the beginning. And even though it looks like a lot of instructions, it’s actually quite quick.

Nice trick !

It is neat!

Also, I found out that using this trick can actually help engrave this Scheherazade page which I had thought - in a much earlier post - to be impossible to do. Turns out it is!

Thank you very much for this very clever and neat trick :slight_smile:

Thanks so much!

Regards,

E.

Thank you for this workaround. The trouble I have is that, in the ‘fake’ bar (the one which is really a pick-up), the whole-bar rest for instruments that don’t play changes to a counted rest (e.g. a crotchet etc). Is there a way to force-input a whole-bar rest? (If I use a semibreve rest it gets left-aligned rather than central)

Whole bar rests are accessible through the right panel > bars > Insert bar rest
Or you can invoke shift-B and write rest in the popover (I just discovered that answering your question!)

Thank you, Marc. You are most helpful.

Best wishes,
Clement

Hi everyone,

This is a fantastic explanation of using Dorico’s ability to have multiple concurrent time signatures for this sort of polymeter.

In case you’re interested, it’s also possible to have matching barlines without having to change bar numbers. Using your example, I input a 9/8 time signature for all staves, then input the 3/4 individually on the Violin II and Viola staves. Then, I selected the first 9/8 barline and re-input a normal barline for all staves (that is, just pressing Enter to close the popover, not Alt-Enter). This resets barlines for all staves.

Then it’s simply a case of inputting the notes you want as triplets/duplets etc and hiding the numbers - on the 3/4 staves, I input duplet quavers/eighth notes and hid the numbers.

Screenshot with signposts attached :slight_smile:

Funnily enough, before I clicked the link I just knew it’d be Jesu, Joy…
Lillie, you might want to fix some rests in your Violin II and Viola staves :wink:

Nice! I remember notating this years ago in Finale using independent time signatures and it was surprisingly pretty straightforward because Finale is completely measure-based (which causes all sorts of other problems). I was able to create a spacing algorithm which allotted the same space to the 16ths in the voices in 3 /4 as to the 8ths in the 9/8 voices. This is actually authentic; it’s the way Bach notated it and it’s also the way it needs to be played, i.e. with the dotted 8th - 16th being tripletised. One could do this in Dorico, too, but wouldn’t it mean having to respace all the 16ths manually?

That’s a very unusual way of spelling “Thank you for taking time on your Sunday to demonstrate something that might help users do things more quickly/easily”, is that American English? :wink:

Naturally you’re right, however I did in fact leave them like that on purpose to demonstrate that for that bar, the 3/4 meter settings still apply by default. Subsequent bars affected by the global 9/8 barline group rests into dotted crotchets, even on the 3/4 staves.

Good guess; it’s actually English from a Londoner with a New York hangover…

Really I didn’t mean to cause offence - I’m sorry! I hadn’t realised you’d left them intentionally to make the point - I just saw the 3/4 signature and the bars not adding up.

no offence taken really, it’s good to have a critical eye - I’m just a big fan of the compliment sandwich: say a nice thing, point out what’s wrong, end with a compliment :slight_smile:

Thank you so much, Lillie and all the others, for adding further refinements to my little trick. I should add that Ricardo Matosinhos has also shared a tip to execute a similar sleight of hand using the playing techniques editor. It is to be found on the FB site. While it is a graphical solution, it has the advantage of not messing up multirests should one not add musing on the individual staff with the different TS until a few bars after the meter change.

Hm. I’ve got it to work putting a 9/8 into a 3/4 bar - brilliant - thanks! but can someone give me a blow by blow account of the reverse please? Having the strings playing in 3/4 while the rest of the band plays in 9/8. I tried Shift-M, 3/4, but didn’t know what to put as the meter, so put 4.5; then Alt-Enter. It could work, maybe, except that the bar now has a crotchet note, 3 crotchet rests and a quaver rest, when ultimately I just want a crotchet and two rests. Sorry Lillie - I just can’t see how you’ve managed it.

It’s fiddlier the other way round, I think.

  1. Put a global 9/8 in.
  2. Add a local 3/4, 4.5
  3. Turn on Force Duration and input a dotted crotchet/quarter.
  4. Invoke the tuplet popover and type 2:3.

Lovely - thanks - I wasn’t so far off then. What bugged me was that I had tried to Force Duration but it didn’t work on the rests; it seems it only works on notes.

Dear piano888,
For the sake of exact statements, I can assure you force duration DOES WORK with rests. You need to re-enter them with force duration on, exactly the same thing than with notes.

Ah, thanks. I tried it on a minim rest - input mode, selected Force Duration and quaver, tapped space; selected crotchet, tapped space. The rest stayed as a minim. That instance would of course be a very odd thing to want to do, but from what you’re saying, it should have taken the quaver and crotchet rests? Hm. It’s of no great import - thanks to all of you, my most recent difficulty has been solved (like all the others!) - but I’m intrigued.