slow & not smooth GUI

Hello everyone!
I recently read the forum & i didn’t find (or maybe its didn’t exist) anyone who have same problem like mine.

first my pc specs: W10 x64, i5-4670, 16GB ram, GPU 1050ti 4GB, SSD system(Cubase), HDD Samples.

The problem is:
when i’m working in heavy project with alots of: audio tracks, vst effects + vsti.
VST Performance meter around 70-80%
No audio glitches/drops etc. audio works ok.
But GUI, its not smooth, not fast, not optimized & have alot of bugs with focus zones…

For example i need to zoom in, select audio part, slice it and move it - and it start be a nightmare, like i play high end video game with low spec pc.
And if open vari-audio in lower zone, and trying to move parts. same problem
When open empty project, Cubase doesn’t have this problem.

And level of GPU usage doesn’t change if u open empty project or heavy.

Maybe this happened just for me, i don’t know.
Maybe MacOS users doesn’t have problems like this, and i should switched to mac…

anyway, I will be appreciated for any advice

Thanks

No, do NOT switch to Mac. It’s a very well-documented issue on Macs that Steinberg is aware of and working on fixing. I’m surprised to hear about it on Windows, and would look at other culprits besides Cubase since I’ve very rarely seen the same GUI issue as Mac users have mentioned for Windows users.

Are you actually using the discrete GPU for Cubase?

Before, i’m using discrete GPU. After i buy MSI GeForce 1050Ti 4GB. I was hoping this will solve my problem, but it not.

i open same project in C7 - NO problems.


i found this kind of issue after C5, with every new version, this issue start be more critical

On Windows:

It’s not just on Macs. Too many MIDI events means moving the mouse makes it stop updating.


EDIT: Fixed in 9.0.20

Interesting! That in particular does not happen on my Mac.

The gfx stutter when moving mouse on a busy project is much worse in C9.
Cubase has never been super smooth, and that’s ok as long as the audio doesn’t suffer.
But in C9 it’s testing my patience.

i found if u hide everything except part u need, GUI start be little bit faster, then everything shows up

Yeah thats right - shove everything in a folder and shut it and the gui issues go away.

In the Nvidia (or ATI) control panel you can set Cubase to use the discrete GPU.

issues doesn’t go away, just little bit less slow. but, still annoying

i working in discrete GPU, it doesn’t solved the problem

But in C9 it’s testing my patience.[/quote]
Same here. Cubase is the only daw that lags on my mac. It’s been like that since cubase 8. 3 years of lag is not acceptable

How do you define “too many MIDI events?”

Can you list a step-by step repro? Not that I really want my DAW to replicate your problem, but are there audio tracks too? How many MIDI tracks? How much CC data?

u can reproduce it not just with midi.It’s happened in heavy project.

Simply play project choose scissors tool, and just moove cursor inside project. While u mooving cursor cubase GUI freezed, stop moving cursor, unfreeze

Goes away for me - certainly seems to be separate from processor load as just a large track count but with minimal inserts can produce lag. With the load meter almost at zero.

That is news to me, can you please give the details on how to do that.

Hi to everyone, just want to help out anyone who is having problems with the gui of Cubase running super slow. My Cubase 7 LE AI got extremely slow when only using 4 vst midi instrument tracks, especially the more I added midi notes and recorded midi CC notes, the whole graphics and program in general began to slow extremely. I couldnt do anything else like basic playing, the sound even just got out of balance and became all choppy, the tempo etc. Couldnt copy and paste or scroll the page forward or rewind etc. Nothing at all, it just stopped running smoothly, so I read up some info and I found out that downloading Asio4all driver fixed this issue instantly by increasing the audio buffer size samples. Completely fixed it and Cubase ran even way more smoother and faster. I stopped using the Generic asio driver that comes with Cubase and switched to Asio4all driver. I also read the help section in the Cubase generic asio app and it said if you run into audio problems like the sound chopping up or other issues to increase the audio buffer size. This is from the help section from the generic cubase asio control panel: “Audio buffer size - Audio buffers affect how audio is sent to and from the audio hardware. The size of the audio buffers affects both the latency and the audio performance. Generally, the smaller the buffer size, the lower the latency. On the other hand, working with small buffers can be demanding for the computer. If the audio buffers are too small, you may get clicks, pops or other audio playback or recording problems. In this case, try increasing the buffer size and/or deactivating the “Allow ASIO host application to take exclusive control of selected port configuration” option. If you activate the “User definable” option, you can use the slider to adjust the buffer size in milliseconds, or enter a specific value in the field to the right.” So I increased my audio buffers to 1024 samples & I also adjusted the option on my graphics card app/control panel to “Use my preference emphasizing to Performance” (performance or quality) (There are 2 other options available also, the "Let the 3d application decide and the "Use the advacned 3d image settings.) My best results so far is setting the graphics to performance mode. I also disabled the windows Aero theme but still have all other options enabled for windows Performance Options - Let windows choose whats best for my computer with all options enabled. I dont have a dedicated audio sound card so Im just using the basic Windows 7 Pro x64 hd audio sound driver. My pc is a 2009 (the year made) Acer Aspire dual core Intel with max ram of 8 gig, hd of 500gb and an optional Nvidia G210 with 512mb ram. Hope this helps anyone, peace.

Cubase uses aero on Windows that uses the gpu, no need to set anything.

The window compositing is Aero, which doesn’t say anything about how Cubase itself uses CPU or GPU to draw the window contents. But that’s determined by Steinberg’s code, not a gfx card setting.

Yes it does Cubase now require Aero to run, Aero is per definition DirectX10 accelerated. That’s the reason to require Aero, to offload the CPU and let the GPU do. the gfx.
I personally had better gfx performance before when it was possible to run in a non Aero mode, but that’s another discussion :slight_smile: