"Soft-elicenser doesn't have enought permissions..."

Hi everyone… brand new problem.

New PC, running Windows 7 (64-bit). Same (Syncrosoft) dongle I’ve been using for years.

Running Cubase 5.5.2 (64-bit)… which worked fine until today.

Just installed a new RME RayDAT sound card (main card is Rev.1.2, daughter card is Rev.1.1).

Then installed GigaStudio 4.01 (64-bit).

Now, every time I do one of two things:

(1) launch GigaStudio, or

(2) launch Cubase after I’ve launched GigaStudio,

an error message pops up that says:

Soft-elicenser doesn’t have enought permissions to run properly. Please run LCC to fix this problem."

[the mis-spelled “enought” is in the actual error message]

If I click “OK,” the programs continue to load… but then, when I try to assign a MIDI port in a MIDI track in Cubase (one of RME’s special low-latency GSIF MIDI ports) Giga crashes. Then, as I try to close Windows, RME driver hdsp64.sys crashes and causes a “PROCESS_HAS_LOCKED_PAGES” Blue Screen.

I’ve had this problem with eLC software v6.1.4.1049, and then with v6.1.4.1050 (which is the current version). I’ve also had these problems with the current and previous versions of the RME driver.

Incidentally, I have no idea what the “Soft-eLicenser ( SeL)” is, as there was no such thing when I started using this dongle.

When I launch the eLicenser Control Center, I see all of my licenses in the “USB-eLicenser” panel, but there are no licenses in the “Soft-eLicenser ( SeL)” panel. Should there be any? Cubase seems to think so…

Any ideas what’s going on?

Thanks!!

^ ^ ^ B U M P ^ ^ ^

Hi Alan, I can’t offer much more than a similar story and sympathy, I’m afraid. Ever since installing Wavelab 7 (in Win7/64bit), if I run Cubase 5 or 6, 64bit, and then start up Wavelab as well (e.g. after an audio mixdown export in Cub6 which can open Wavelab immediately with the mix in it) I get that same message (inc. the spelling!). Don’t get it if I open Wavelab 6 instead of 7, and don’t get it for any of them on their own.

In my case it seems to be completely spurious, as Wavelab actually opens and runs fine, but at least I hope that’s some help with giving more information! I’m using eLicenser 6.1.2.4044 so I guess it’s not totally new to the app.

Please, somebody… for Bill M’s sake and mine…

What is this “Soft e-Licenser”… which doesn’t seem to be installed on my Syncrosoft dongle with Cubase 5.0 but which does seem to get installed on the dongle with the 5.5.2 update?

Why is the this “Soft e-Licenser” installed when I have no new licenses to put on it?

Why does Cubase keep telling me that the Soft e-Licenser “doesn’t have enought permissions” when I have licenses for all of my programs in the regular “USB-Licenser” section of the “eLicenser Control Center”?

Why does the “eLicenser Control Center” then tell me, each time, that “[t]he recovery process didn’t find any issues which could be solved”?

? ? ? ? ?

Hello,
Some Steinberg OEM, LE and Sequel products do not need a hardware “USB-eLicenser/Steinberg Key”. Instead they use a virtual “Soft-eLicenser”. If you have never installed an OEM or LE version there should not be a Soft- eLicenser present on your systems HD.

Try this to solve the permission problem:
Download the latest eLicenser Control Center from www.elcc.eu.
Right click on the installer and choose “Run as --> Administrator” so you install the eLCC as Admin.
Now search for the eLicense Control Center in the Windows Start menu and right click on it. .
Right click on the eLC and choose “Properties–> Compatibility–> change settings for all users–> Run this program as an administrator”.

Does this solve the problem?

Gr,
JHP

Hi JHP,

I did exactly as you suggested, and nothing has changed.

The USB-eLicenser shows up in the Windows Device Manager as an “Unknown Device” with a yellow exclamation point.

The USB-eLicenser DOES NOT show up under the list of “eLicensers” when I run the eLC software (version 6.1.4.1050).

While the USB-eLicenser doesn’t show up, I still see a “Soft-eLicenser” under the list of “eLicensers”… with no licenses assigned to it.

What should I try now?

Thanks,

— Alan

If you do not have any license on your Soft-eLicenser you may want to delete it.
You can delete the Soft- eLicenser by closing all programs and deleting the file “SeLicenser.sel” from the following path:
Windows XP
C:\Documents and Settings\All users\Application Data\Syncrosoft

Windows Vista / Windows 7
C:\ProgramData\Syncrosoft\

Mac OS X
/Library/Application Support/Syncrosoft Soft-eLicenser/SeLicenser.sel

It is not usual that a USB-eLicenser is not recognized when you run eLC software (version 6.1.4.1050).
You should try to restart your system and connect the USB- eLicenser to another USB port of your system.
Windows should detect this as new hardware. Click on next, next, next and “automatically” install the device through the “new hardware detected” dialog.

Gr,
JHP

I wonder if the problem could be something to do with the time-limited mp3 Encoder license? Even though I have full Cubase (which includes the mp3 encoder) this ‘Demo’ version still seems to live on the Soft-eLicenser, and perhaps this is the item that ‘doesn’t have enought permissions’ to run in Wavelab at the same time as Cubase?

Even if this is the case, I could still delete the Soft-eLicenser as suggested, since I don’t need the mp3 encoder demo.

Thanks, JHP.

I deleted the soft elicenser as you explained, and now that pesky MP3 Demo license is finally GONE from my elicenser. Also, now I don’t get error messages each time I open one of my protected applications.

Way to go!!!

Thank you that solved the problem for me, Cubase and eLicenser were having a problem. I had repaired disc permissions several times, rebooted and even did repair permissions in safe mode.

“Doesn’t have enought permissions” was the same error I was getting on a Mac.

Solved mine in Cubase 7.5 & WaveLab8 … THANKS!!! :smiley:

Thanks JHP, solved it for me even in Cubase 8.5 on windows 10.

hi guys

my new 8.5 midi worked just fine the past week

have the dongle…

suddenly got the message today when opened cubase

and since than cant open vst instruments and midi input even not showing ant signal

though when i open cubase or lcc the message is gone…

what should i do? download the elcc ? (why if it had been running fine and did all updates…)

tnks

Worked for me too…

The soft-elicenser was giving me problems all of a sudden (it may have sth to do with the Windows anniversary update) until I started the eLicenser Control Center as administrator (Run as -> Administrator like JHP suggested). Then I let it run thru it’s maintenance and everything was fine once again.

Wanted to report that I just encountered the same issue, and the “Run as Administrator…” suggestion worked for me too.

On that note, the last Windows 10 update caused this issue (along with a few others). It was one of these two updates, which both applied today:

2017-06 Cumulative Update for Windows 10 Version 1703 for x64-based Systems (KB4022725)
2017-06 Update for Windows 10 Version 1703 for x64-based Systems (KB4022405)

In case anyone is interested!

Mine is weird. My Cubase 9.5 was running fine since I got it the day it came out. But the last week after windows 10 updates. I get that error message now about permissions. I updated the licenser, uninstalled and reinstalled everything, updated Cubase and switched USB ports for the dongle. But the only way to get everything to work without any error messages, is to run as admin my licenser center first, it then opens, then open cubase 9.5 as admin, and then everything opens and runs. If I do not open the licenser center first, and just open Cubase 9.5 like I used to by clicking on the icon etc. Then I get the error message. weird.

Kind of annoying. Any fixes?

“Run as Administrator…” suggestion didn’t work for me so i tried Properties > Compatibilty > Run compatibility troubleshooter, & that solved the problem :slight_smile:

Hi Mate.

I’m had the exact same issues. That latest windows 10 update completely ruining my PC.
So, i uninstalled, re installed, ran as admin, then as not. Ran in compatibility mode, then not, then it seemed to work.
Its odd. Took about 20 attempts and running a maintenance task in every way. Finally just seemed to work in normal mode (no admin, no compat mode).
Fingers crossed it still works when i boot up again.

AMD FX 8320 ( 8 core CPU ) Cubase 9.5 upgrade from8.5 running win 7 x 64 bit , same old mesgs , never got to load C pro 9.5 so far … waiting , now getting DCOM connection to program 'Synsopos.exe failed, Error the RPC server is unavailable. done all the above run as admin etc … My licenses show NOn Movable Remaining time , 12 Hrs 18 mts n 18 sec … now nothing works including the Cubase 6 , i had , n gone are the linceses for C 6 , C 8.5 etc … even Halion shows 4.X n Groove agent shows 4.X . think it used to show the . 5 versions … any one suggest please thanks ws

I had similar problems. For me, the problem was with the “Soft e-Licenser (SeL)”, which no longer recognized my computer after one of the major Win10 updates.

I logged in to my Steinberg account, went to the “My Products” page, and clicked on the “eLicensers” tab. I could see that one of them was no longer valid.

All of my software was registered on the ‘hardware’ eLicenser, so it was easy enough for me to delete it. If you have programs registered on it, becareful — you don’t want to delete any software licenses.

At that point, I would contact Steinberg support, but at least you’d have something specific to show them.

See also: https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/win-windows-10-upgrade-disables-soft-elicenser.html

Good luck, everyone!!