[SOLVED] News update: Cubase iC Pro connectivity issue

I have never downloaded any version of this App, but these features are something I was looking into and now I want in! I’m wondering, if I try the Beta of iOS 11 will it be available for download, or am I out of luck now.

Hi all,

Our testings with Apple’s official iOS 10.3.3 release are positive so far, and their update solves the iC Pro connectivity issue.
Please expect an official news update from us in a few days.

Best,
Lars

Yes it works again with 10.3.3 on my iPad Pro.

GREAT!

10.3.3 works fine on my iPad 2.

I’ve just updated my iPad to 10.3.3 and can confirm the fix in my environment.

While I’m glad to see it working again, I couldn’t wait around for a solution. I’ve mirrored my monitor output to run an additional one in the live room, and just use a wireless keyboard and mouse to control Cubase. I can’t live in fear of iOS updates breaking things my studio depends on if the company I bought it from isn’t keeping it up to date with bug fixes.

For those who don’t have this app and are considering a purchase, I would strongly advise finding a different solution.

I’m a big fan of Cubase and continue to upgrade. However, since the IC Pro app is no longer being maintained, it simply can’t be trusted as a reliable part of a production environment. The next time an iOS update breaks it (not an unreasonable scenario) you could be down for yet another three months, waiting on multiple versions of the OS, and hoping each time that Apple fixes the problems. If Apple hadn’t decided to address this in a new iOS version (also not an unreasonable scenario), it would simply be money down the drain.

Yes. It’s probably not wise to use a $15 mobile app as a solution in a single-point-of-failure configuration in a professional studio.

Yes working but I too will not rely on this app anymore and use PT control. Months of downtime is ridiculous. The method use to connect has to be suspect since other apps connected fine while this didn’t. Apart from still using Cubase I won’t be buying anything else from SB as the support is atrocious. As mentioned in an earlier post they certainly seem to abandon the none premium software on a regular basis

It works but does not show the different channels in cue mix mode, even they are activated
Any one here who has the same bug and also a solution?

Greetings, Olaf

This might be caused by the VCA bug. It has been acknowledged by Steinberg, but not fixed of course.

See here:

https://www.steinberg.net/forums/viewtopic.php?f=174&t=110725

Hi all,

As stated before, our testings with Apple’s official iOS 10.3.3 release are positive so far, and their update solves the iC Pro connectivity issue.
Please expect an official news update from us in a few days.

Best,
Lars

Thanks for that. I have a license for the discontinued android version, but now own a ipod air iOs 10.3.3. Do I get any credit toward the iOs version?

Thank you, Chris. The Problem was the VCA Faden bug.
Hope Steinberg will fix it asap.

Greetings, Olaf

Dear all,

On July 20, 2017, Apple released the latest iOS update version 10.3.3 and we are pleased to announce that this resolves former connectivity issues between Cubase iC Pro and supported Steinberg DAWs.

Please follow this link to learn more:
https://www.steinberg.net/forums/viewtopic.php?f=174&t=121062

Best,
Lars

Hi,
New Ski Remote 1.0.8 states a minimum of Cubase 8.5 or later, and also Windows 8 minimum…

However, it seems to be working with Cubase Elements 7 and Windows 7 x64 as far I can tell.
Haven’t updated to iOS 10 yet though, so if anyone is running an older Version of Cubase/Windows and can confirm that it works ok under iOS 10 that would be great.
Cheers.

@Lars Any idea on this? Are the minimum specs stated on the SKI installer just a guide to what is officially supported or am I likely to run into problems with my older version of Cubase/Windows?

Hi,

The system requirements state the officially tested and supported operating systems.
Cubase iC Pro might run fine on older hosts or operating systems, however these have not been tested and are not officially supported.

Best,
Lars

Hi Lars,
Thanks for the clarification.
If anyone has tested an older setup like mine with iOS 10, I would appreciate it if you could confirm it is working.
Cheers.

I’m running Cubase 9 so I can’t confirm that part, but I am running on Windows 7 64 bit and and the app works on 10.3.3.

Cool, thanks for the info.

I can confirm that it is working with my Win-7 64bit system using IOS 10.3.3 on my iPhone 5 and IOS 9 on my iPhone 4S.