Steinberg Activation Manager keeps asking for activation

Everytime I launch Dorico 4 on my desktop running on Windows 10, Steinberg Activation Manager asks me to activate my license. And indeed, my Steinberg web profile says that Dorico 4 is not activated on any computers, despite the fact that I tried to activate it several times already.

I suspect this issue is related to the fact that my OS user name contains a Unicode (non-Latin) character (Miloň). I have come to this suspicion because when I run Activation Manager with admin rights, a new folder with a distorted variant of my user name (MiloĹ) is created in “C:\Users” directory and it contains the following path: “C:\Users\MiloĹ\AppData\Roaming\Steinberg\Activation Manager”

My Windows locale is Czech.

So, Steinberg, have you tested your Activation Manager on Windows 10 under an OS user whose name contains Unicode (non-Latin) characters?

Thanks in advance for looking into this issue!

Miloslav

We had another user with a similar issue who found that if he deleted the directories with the wrong name then SAM would work: Authorize Steinberg Activation Manager - #27 by MilosBetko So can you try deleting the whole C:\Users\MiloĹ directory?

As you can see from the timestamps in the screenshots in his thread, the incorrect user directories were quite old, so I suspect it is not Dorico that is creating those incorrectly-named users, but it does look like Dorico might be confused that they are there. I wonder if there was once a Windows bug that generated those directories.

Also, can you let me know what exact version of Windows 10 you are using, as far as language is concerned? We can certainly try creating a user with a non-Latin username, but it may be that the result will depend on the OS as a whole.

Hi, Richard,

thanks for such a prompt reply! I’ve just deleted the “C:\Users\MiloĹ” directory, re-launched SAM with admin rights and that directory immediately appeared again. So, in my case, it seems it is really SAM who is creating that incorrect folder. My OS version is Windows 10 Pro 21H2, build 19044.1466

When I run SAM itself, it also still asks for login in. As if the application data is not being saved at all.

If you copy the data from C:\Users\MiloĹ\AppData\Roaming\Steinberg\Activation Manager into the equivalent directory in your real user account, does it then work?

Also, can you show me the settings on the Language page of your OS Settings, i.e. this page:

Unfortunately not, copying the data from C:\Users\MiloĹ\AppData\Roaming\Steinberg\Activation Manager into C:\Users\Miloň\AppData\Roaming\Steinberg\Activation Manager does not seem to help. When I sign into my account, close SAM, and re-launch it, SAM is asking me to sign in again.

My language page in OS settings looks like this:

OK, thanks. I’m very sorry about this, but we’ll have to investigate a bit further here. I will update you when I have some more information.

Okay, thanks so much! :+1:

I have another piece of information for you which might be relevant for the investigation. I went to “Language settings → Related settings → Administrative language settings → Language for non-Unicode programs → Change system locale” and there I ticked the checkbox named “Beta: Use Unicode UTF-8 for worldwide language support”.

After I did that and restarted PC, SAM is working as expected! No more it asks repeatedly for signing in and I have also succesfully activated my license, therefore, now I am finally able to launch Dorico 4. I would say that this observation confirms that there is a language issue involved.

Aha, that’s extremely interesting, thanks - that will definitely help me investigate this.

I can reproduce the problem here on a test virtual machine, so hopefully that will enable one of the developers here to take a look.

1 Like