Track delay issue

I’m using a negative track delay of -30 milliseconds on a midi track so I can get a fast staccato violin completely in sync with the click.
But this makes some of the notes skip once in a while. A look at the midimonitor shows “outside Prefetch” when it happens.

What to do ?

Maybe move the notes or midi part, instead of doing a neg track delay.

Also, have you checked to see if this doesn’t actually happen without the delay? (to avoid a red herring)

Yes - I just got the same idea and it works, but then I also have to fiddle with the score.

Sure :cowboy_hat_face:

So fast tempo with 16ths or shorter? Have you played with Display Quantize in the Score?

Yews - I’m all over the place :slight_smile:
The score needs to be nice because it’s the basis for import into Dorico…

I wonder if this could be improved with using a better clock source. Do you have a good audio interface that has a good clock that you could use as an External Clock for Cubase? Pure speculation but if you’re trying to make adjustments in the tens of msecs then the tolerance could be in the 100’s of usec range and I would think a more accurate clock source would help avoid those “Outside Prefetch” errors. If you have a better clock source available it would be worth checking out.
If you are playing these parts in as opposed to entering them manually in the Key Editor, try checking the Use System Timestamp in the Studio Setup > MIDI Port Setup if you don’t have a better clock to use. That may also give you more accurate timing than the internal Cubase timing.
Here is a quite old article, and I realize a fair bit of the info may be outdated, but there is still some good background info on how MIDI timing works.
Cubase: Solving MIDI Timing Problems

Here’s the MIDI Port Setup

Nice suggestion, bit I’m using an RME Fireface UFX II which has one of the best clocks available. And since the problem goes away, if I shift the midi parts instead of the whole track, I think the problem lies within Cubase.
Thank’s anyway :slight_smile:

Exactly, I use an RME Fireface 800. But if you’re using the default settings in Cubase, you’re using Cubase’s clock and not the clock from the RME. You have to tell Cubase you’re using an External Clock to take advantage of the RME. The Use System Timestamp uses Windows clocking, which apparently, can be better than the software clock Cubase uses by default, but won’t be as good as your RME.

Interesting :thinking:
Are you saying, that I should tick this:
But clock source settings are greyed out…

Yes, try ticking that. The clock source is grayed out (I think) because it is controlled via the control panel for the RME and/or the Snyc Setup dialog. I think if your audio device can’t output a clock signal then that menu is active, but that is speculation. It doesn’t say specifically in the manual. When you use the external clock setting the transport is controlled by the Activate External Sync icon down on the transport panel. Next to it is the Project Synchronization Setup icon to set your sync source and other parameters.
Not sure this will work for this issue, but it’s easy enough to give it a try.

The Asio Audio device is greyed out :thinking:
I have these settings:

I’m at a loss there. Nothing I could try on my end caused that to become unavailable. Sorry.