X-Touch Midi Remote Cubase 12

Page? What page?

The different pages setup in the midi controller. There are already next and previous page commands but I dont really want to have to press several time to get to the page I want.

@C.F.Christopher Hey, just got my xtouch yesterday and had the same idea - setting it up via Mackie Control + additional midi remote. However I have functionality out of the box for some of the buttons you mentioned (firmware 1.22 too). E.g Modifier->CONTROL opens “save project”, ->ALT opens “last version”, Marker and Nudge buttons go to locators left/right locations etc. If I use a midi remote script I can assign other functionalities which work - but pretty sure this will mess up sooner or later. Wonder why I have functions on those buttons and you dont?

I think he probably does have functions on thos buttons (as do I) but possibly assigning new function in remote midi overides them where as with the controls in the red box I think there are problems.

Hmm I doubt it will really overwrite aynthing tbh as the data will be received by both “remotes” (mackie control + remote script). Might be wrong but for now I just programm the non functional buttons.

There must be somethng happening as Chris above posts about using only some of the buttons as a handful cause issues if you try program them in MC mode?
I will be having a mess around later but pretty happy to have around 35 buttons I can configure myself. Add in the ability to have multiple pages and thats quite a few commands at your finger tips.

Maxx yes that’s correct. On the items like CONTROL and other buttons that do work but don’t work for the task they should I changed them. So far all is well. It turns out the CANCEL button work as a Deactivate of all Solos. I just found this out last night. I originally programmed CANEL as the ESC key but since I learned that it works in Mackie mode I left that button out of my Midi Remote mapping and it works great as all solo defeat.

I’m not sure if it’s “overwriting” anything David but it does “take over” control. So when you Midi Remote map buttons/controls it does cause Mackie to stop working on that control. At least that’s what I’m finding now.

1 Like

Hey Maax,
Yeah it’s been working consistently. Obviously if SHIFT, OPTION, CONTROL and ALT buttons worked as Modify buttons you would have four times the use on the 35 or so buttons that are programable but I just ordered an X-Key 24 button and 16 button controller that I’ll be mounting on the desk edge in front of the X-Touch that I’ll be able to use my thumb to press and the 24 button pad will be mounted to the right of the X-Touch that will give me even more control. The X-Key software is freaking amazingly powerful!
I’m not done figuring out how I’m going to program things but I broke Cubase key bindings down to four categories. Dialog Windows : this triggers windows like Mixer, or MediaBay, etc. Processes: this is for things like Render in place, Normalize and other audio or MIDI processing tasks. One button press can trigger a macro or just run the task in Cubase if it will run with a single press…if not X-Key software can allow you to set up macros. Next category is Transport: this is anything related to transport like of course the normal functions like play, stop FF, RW, Jog…etc. but also Set right and left locators, marker sets, go to Left Locator, go to right locator, go to marker number X, etc. The last category is Functions…everything in function category is thing that don’t fit into any of the other primary categories. I’ve decided that the “Transport” button that I need (that are not already available on the X-Touch) will be programmed into the 16 key X-Key unit mounted on the front edge of the X-Touch. This will be great to have everything that I’ll need with a simple thumb press. The other 24 button X-Key pad will be used for the various functions that I’ll need. Between the X-Touch and the two X-Key pads I’ll have more than enough of one button functionality.

I have a controller like that set up with an old 10" tablet and the software touchOSC. Maybe an alternative to the -as I saw- pretty expensive controllers. Advantage is - you can literally create hundreds of buttons/faders/encoders etc and assign them as you want - for much cheaper.

1 Like

I’ve got an iPad with the Cubase ic remote on it which is excellent. I’ve also got the cmc 6 controllers which are also very good and obviously have all the mapping done and also quite a few buttons to use with shift. Together with x Touch, Maschine Studio and the Komplete Kontrol S61 mkii I have more than enough physical controllers but I just can’t resist shiny new stuff and will probably add the steamdeck xl. I think I spend more time messing about with controllers than actually creating music :weary:


In mackie mode, it’s normal those assign buttons (see picture).

LOL you really made me laugh Maax! Your last sentence is actually why I’m kind of upset with all this manual mapping of the X-Touch. I’m finding myself messin’ around with gear rather then making music…again! I hear you. Can you snap a photo of your setup? I’d like to see how you got things setup if you don’t mind.

1 Like

I ve not had a chance to mess around much this weekend. My studio setup is in one half of my loft. Its not a great setup at the minute as i just built a vocal booth but it took up a bit more space than i imagined. I tried to upload a quick video but was way too big. will sort a couple of pics out.

1 Like

Ok I gotcha. Well when you have things set up and feel comfortable and don’t mind snapping a photo or two let me know if you would.

Ive downgraded the video in an attempt to upload so quality is sh*t now :frowning:

1 Like

Hey David. I do have functionality but a button labeled “CONTROL” and “ALT” should work as modifier keys which would give use MUCH more functionality with the other buttons. So rather than leave them to something they aren’t labeled for I changed them. IF the X-Touch gets a script from Behringer for Cubase or the Cubase dev. community makes one to make these keys function as modifier keys I’ll use them again. I was using the SHIFT and OPTION to work as go to project start and end and the CONTROL and ALT to go to left and right locators but I found a Much better solution in my X-Keys programmable keys that I installed against the bottom edge of the X-Touch. It allows for my thumb to make very quick use of these common tasks and other things related to Transport functions. The other 24 key pad will be used for everything else. I’ll reprogram the “Modifier” keys on the X-Touch to something else once I know what that is. I just added two heavy duty commercial grade cast iron pedals and programmed the foot controller jacks on the back of the X-Touch. One turns on/off the metronome and the other is record/punch in/out. I have a song that I need to disable the click at the end otherwise it distracts me big time. Now I can just click the pedal in the last measure of the song and not get distraction to end the song properly.

EDIT: Sorry, scrub that entire post (about not sending messages) , I forgot I had Bome Translator set to swallow the messages! Closing that, it actually does all work as intended - the fader moves when selecting each track as it should. SO in fact, it does seem the Xtouch One is working fine with the new editor!

1 Like

@Jochen_Trappe I am just getting around to finishing setting up my Xtouch One, and have a problem with selected tracks, and I am wondering if it is a) by design or b) a problem with the Xtouch. Basically, if I choose a ‘Selected tack’ command, like Solo, Record Enable or Mute, it only works for Audio and Instrument tacks - it doesn’t’t work for folders or MIDI tracks. This is not the case in Nuendo 12, where it works for all tracks. Any idea what is going on? Thanks.

EDIT: For info, if I revert to using the legacy Generic Controller instead, then the ‘Selected Tack’ function works as it should. So, I am guessing this may be a bug? It’s Nuedno 12 by the way, not Cubase.

Hi @stevefoxon, the MIDI tracks issue will be fixed in the next maintenance update. I’m a bit surprised that they work in Nuendo. Or are you using Generic Remote or Mackie on Nuendo?