Auto-Save not working properly

It seems that the auto-save that one configures, for example every 3 minutes, is not working as expected in Cubase 12 latest update… it’s been several times that Cubase freezes, and the auto-saves do not correspond to 3 minutes each one, the last time it was more than 15 minutes since the last auto-save…

Cubase “freezes?” Not sure what you mean by that when addressing Auto-Save. Do you mean it locked up therefore you need to go to the last Auto-Save and it happened 15 minutes ago?

You realize Auto-Save is disabled when in Play or Record modes correct?

what @Greg_Purkey said, also auto-save won’t run if nothing has been edited.

When cubase freezes I mean it literally and it is that Cubase has crashed, the autosave of cubase 12.0.50 does not work properly, since in one of those freezes/collapses, I have lost probably 20 minutes of working edits (which is quite a lot) when fast progressing.

You can see in the example image below that the autosave goes completely random in times;


Please Note that Technical/developers support is aware regarding the freezing dumpfiles, however this is something else that should be attended too.

Do you edit with playback running?

Yes… is the reason why I have opened this topic, as with this problem, I have already lost important advances a couple of times.

I see.

For better or worse, autosave does not run when playback is active.

Maybe I’m not understanding what you mean by “playback”?

However what I am reporting here, did not happen in the past in Cubase 11, I work many hours a week, in which my configuration is auto-save every 3 minutes, since I make critical advances, and for the same reason I have never lost important or critical advances since I used that configuration in Cubase 11, now with the Cubase 12 update, I am having this problem, reason why, I emphasize again, I have made this report since I think it should be reviewed and addressed, being that it is not a normal behavior of Cubase 12.

Playback = whenever the transport Play function is active.

ah ok, then no… I edit and then put play, that’s my workflow since years ago, I get to make small edits of automations in “playback” however, what I comment here refers to times when I pause to edit and as you can see the difference in times when cubase auto-save is bigger, which means that Cubase did not take into account many of these pauses to auto-save.

I emphasize, did not happen in Cubase 11, not that I have changed my workflow from one version to another … and now I am forced to be pressing cntrl + s every time I make even small or bigger advances to not lose anything, which is really annoying.

When you are playing back for a longer period of time than has been set in autosave prefs, (3 mins in your case) auto-save should kick in right when you hit stop.

I understand how you might come to that conclusion. If there is indeed a bug needing fixing, a reproducible sequence of steps to use for a bug report would be necessary.

If you feel like spending about 15 minutes testing, here’s a repro sequence you can use to confirm (or not confirm) the possible bug. I have just done this, and could not reproduce the issue.

Do it in Cubase 12 and Cubase 11 to gain an objective perspective on the problem.

issue: autosave is not invoked

Repro:

  1. Launch Cubase, go to preferences and set auto save for .5 minutes (the shortest possible interval).

  2. create a new project, with a new midi track, and draw in a midi part on the track

  3. Save the file with an obvious name (I used ‘auto save test’)

  4. move or cut the midi part (do not hit play) to mark as needing saving.

  5. Open the project folder to observe files as they are created. Set the view to Details, and sort by date descending (newest at the top).
    Wait for a .bak file to be created. Once it has been:

  6. hit play, and while playback is active, edit the the midi part again so there is something to save.

  7. wait for 1 minute and 10 seconds.

  8. Hit stop.
    → a new .bak file should be created.

by the way, there are no crash log files in the directory in that screenshot, just projects, backups and *.csh files which Cubase uses in the background.

Guys, I have no idea why auto-save doesn’t work properly for @Nordlead27.

Just an idea: The projects have quite a huge file size. If everything else is ruled out as a factor, maybe that has something to do with it.

my crash dumps are not generated in the same folder as my projects… in case you have any doubts about what I am reporting, here is a screenshot from Steinberg support.

Moreover, I hope that in your effort to reproduce the problem, you have chosen a long project and not a clean project, besides setting the auto-save every 3 minutes and you have done so under realistic operating conditions. Thank you.

freeze

And in case you need to verify further, here you have all the freezedumps, although I doubt you will be able to check them, since this is a job for the developers…

Cubase-freezedumps.zip (2.8 MB)

Could be.

It would be also informative to do repro using your current project.

RE the crash logs, I just thought you were referring to the screenshot right above where you said: