Bug with Trills in Condensed Score

Hello all,

Is there a known bug when using trills on transposing instruments in a condensed score?

I am working on a passage in which there are two clarinets playing sustained notes in the same rhythm, but one of them is trilling while the other is not. Everything is fine in concert pitch and transposed pitch before condensing and also fine when condensed in concert pitch. However, when I turn on condensing while set to transposed pitch, the interval indications for the trills seem to be bugged. It is not just a problem with the file I’m working on (which was converted from Dorico 2.2) because I was able to recreate the issue in a freshly created test project.

When trill interval appearance is set to auxiliary note, the functionality is completely broken. The auxiliary note always appears as C5 in treble clef and has an accidental pertaining to whatever the accidental of the trill in concert pitch would be.

When trill interval appearance is set to accidental, it seems to incorrectly convert the trill accidentals that change due to the transposition. For example, if I have a clarinet in B-flat playing a concert D that trills up a whole step, when I turn on transposition, the trill fails to display a sharp although the written transposed trill should read between E and F#.

Here is a small Dorico file here where the issue is occurring: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Here are some screenshots for your convenience.

Related issue (I think) with two different trills being condensed incorrectly.

Here are the separate staves:
Screen Shot 2019-09-15 at 9.14.20 PM.png
And here’s the condensed staff:
Screen Shot 2019-09-15 at 9.16.18 PM.png

I can confirm this problem, and we will sort it out as soon as we can.

Thank you :slight_smile:

Daniel, since the problem I listed is different than the OP (but possibly related), could you please confirm that you are aware of both symptoms? I just realized I wasn’t clear on your wording. Thanks much.

Thank you, Daniel!!

Disappointed to discover that this was not addressed in Dorico 3.0.10. Any publicly acknowledgeable plans for it?


It remains on the backlog to be fixed.

Okay, thanks. Fortunately I don’t have anything due soon! :slight_smile:

Are there any good workarounds out there?



Just wanted to check in to see if there has been any progress on fixing this bug, or if anyone knows of a work around. I’ve run into the same problem in a score of mine, and would love any help I can get!


I’m afraid as yet this problem remains unsolved, and at this point it is quite possible that it will not be fixed in the next update, but it is among the higher priority outstanding items for condensing for us to address.

Just ran across this myself, still seems to be present in the latest version (screenshot below.) Are there any workarounds for this at the moment while still using condensing?

1 Like

I can confirm that this bug still exists in 3.5.12. I suppose a workaround without using manual condensing changes would be to create a parenthesized, stemless grace note before the trill, but I don’t think it would then be possible to move that grace note to the right side of the trilled note. Maybe I’m wrong about that.

You could also switch the trill appearance to “Accidental” which, in condensing, also does not work and doesn’t display any accidental. From there, you can add the auxiliary note in a graphic editor.

I know the development team is working tirelessly to meet the demands of all of us on this forum, and for that I am extremely grateful! It also must be acknowledged that this is a bug which affects an extremely common notational practice and, in some cases, could render the condensing feature completely useless. If there’s any possibility of a small update before 4.0 that would solve this issue, it would be greatly appreciated. Within the scope of my own work, this is the only basic thing that Dorico still does not produce correctly.

1 Like

I’m afraid this is still on our backlog to be fixed, and I can’t promise that it will definitely be addressed before the next major version, but I know it’s important.


Hi, Daniel. Is there a recommended workaround for this problem? Thanks!

I’m afraid there’s nothing I can think of at the present time.

This is kind of hideous, but it seems to work, at least in a trivial case.

Start with usual trills (I’m assuming you’ve got your Engraving Options set to show bracketed auxiliary notes and trill lines).

Add a grace note that follows the trill.

In Engrave mode, bracket your grace note - if you want round brackets they won’t show unless you also turn on the Break bracket property.

Then Hide Stems.

Set the Trill Appearance to Accidental. You’ll need to do this for each of the two trills.

You may also need to set the Accidental property, immediately above, to Hide.

At least in my trivial example, I found that the Note Spacing handles don’t seem to work for these stemless grace notes, however the Voice column X offset property does seem to work. You’ll have to do it by eye.

I note also that this has decreased the length of my trill line, so you’ll need to drag that back over to the right.


You’ll then need to repeat most of this in the part layouts.

addendum: if you have real grace notes following the trill, this should still work.
Add them all at the start, then select the second of the grace notes (which will be the first “real” grace note) and use the Edit > Beaming > Break Beam command.

All the other steps remain the same. End result:


I am sorry to report that I am still having this issue with the current version of Dorico. Has there been any progress in fixing this bug?

1 Like

No, as yet this bug has not been fixed, I’m afraid. Sorry for the continued inconvenience caused.

1 Like