Cubase 11 bug: pressing "ctrl" will unselect a midi note

This bug is only in Cubase 11 (Cubase 10.5 works fine)

The problem: Select a midi note, press contrl (ctrl) in 1 sec and the midi note will be UNSELECTED. Why?

If I wait longer than 1 second after selecting a midi note, then pressing ctrl will work correctly.
I am used to working quickly with midi so this makes “midi note nudge” (ctrl+arrow) unusable.

I also opened Cubese 10.5 and pressing ctrl immediately after selectig a midi note works fine.

My specs:
Cubase pro 11, win 10



Could you try in Cubase Safe Start Mode [Disable preferences], please?

Hi! I tried it in Safe Mode and preferences disabled. Still the same error. I select a note with my mouse, I press ctrl or shift and the note will be unselected. I found that it does not happen when I select notes with keyboard by pressing arrow left/right. It happens only when I select a note with mouse.

I can confirm this since I just got Cubase 11 trial in order to give it a shot. and stumbled on this same weird behavior that doesn’t manifest in C10.5. Especially annoying when you select note +Shift for transposing octaves, slowing workflow significantly.

  1. Click on midi note
  2. Than right after hit shift(or control)
  3. Result: note become deselected.

Note: Shift/Control has to be pressed fast after click.

Luckily I didn’t buy update for C11, another show stopper for me.

@Martin.Jirsak can you please confirm this or report to Steinberg? Thanks :slight_smile:


I have seen this report in the internal Steinberg database, so it has been reported already. Myself, I can’t reproduce it.

Awesome, thanks for letting us know Martin :smile:
It’s pretty simple (at least on windows Idk if same behave on OSX)
You have to do it fast (in less than a second) just click on the note and pres shift and hold, it gets deselected. Tried on 2 different windows machines and i can reproduce it every time.
Maybe you tried but not as fast enough or that doesn’t behave on a Mac ecosystem.

Happy New Year btw :wink:

I just downloaded the cubase pro demo and found this bug in less than an hour. So I guess it is still not fixed.
I think I have some more info on what is happening here though.

It seems as if you click on the note and press a key on the keyboard before the note stops playing, it will actually trigger another mouse click.

For example:

In the note editor;

Click on a note, to make it play. press shift before it stops playing and it will trigger another mouseclick, which deselects the note.

Click on a note. Press alt ( cut tool ), and it will trigger a mouse click, cutting the note.

Only fix for this right now, seem to be to move the mouse out of the way of the note, so the click is not triggered on the note itself.

Yes, I can confirm, the bug isn’t fixed.

Best regards,

Pro v11.0.10 Build 321 - Issue still persists.


  • Click directly on a midi note to select it
  • Within about half a second, press and hold either Shift or Ctrl

Expected behavior:

  • Note is still selected

Observed behavior:

  • Note is deselected

This will not happen if the note was selected by click-dragging an area around/over the note.
This will not happen if the shift/ctrl key was pressed after more than 500ms.
This will not happen if shift/ctrl is not held down.

This behavior very frequently conflicts with the editing of notes while using hotkeys extensively (if these hotkeys utilize shift or ctrl).

1 Like

Having same issue here.
This wasn’t happening in v10.5, maybe something to do with the new double click deletes note?

Hi all,

We are struggling to reproduce this. Are you having this issue only on Windows or also on macOS systems?

1 Like

Hi @Matthias_Quellmann , It’s windows for me.
I just sent you an email with a video demonstrating the issue.
Hope it helps.

It’s windows for me, too.

Hi @Matthias_Quellmann,

I could also reproduce it, pretty much like @NoiseInTheDark described it as “timing related”.
The deselection “sometimes randomly” doesn’t happen, since only sometimes - when clicking the next MIDI event at a certain speed and when pressing the CTRL key only for a very short amount of time - no deselection takes place.
Whereas in Cubase Pro 8.5.x and 10.5.x nothing of that sort happens at all.

[edit] Another detail:
in C Pro 11 and key editor, only when pressing CTRL slightly too long / deeply, a MIDI event’s deselection would occur. [edit]

(Win 10 20H2, latest official build 19042.867)

  • Cubase Pro → unexpected deselection effect is there
  • Cubase Elements → unexpected deselection effect is there
  • Cubase Pro no effect
  • Cubase Pro no effect [edit]
  • Cubase Pro no effect
  • Cubase Pro no effect [edit]

[edited: March 15, 2021]


yep, same here on W10 (haven’t updated to 20H2 yet)

it won’t deselect if the cursor is not on the selected midi note, so in order to reproduce this don’t move the cursor between selecting the note and pressing ctr or shift.


The temporary solution, before it will be fixed, you can change the settings, to don’t delete the MIDI Note when double-click, but open the Note Expression editor instead. This should fix it for now.

So, is this still an issue?

Yes, still an issue.

All best,



As far as I know, this one was fixed for Cubase 11.0.20 update.


Thanks Martin, I updated to Cubase 11.0.20 and yes, it is fixed.

All best,


1 Like