Cubase bug midi cc causing jerky mouse movement

Since several months I am having an issue with Cubase 12 and my mouse.
I believe it was caused by an update of Cubase, but I am not sure because I have not been using Cubase for several months.
Now, whenever I add one CC lane (CC 1 Modulation) with a linear curve from 0 to 128 and play it, my mouse gets jerky. Meaning, that if I move my mouse it will not move smooth but in bigger steps, as if the CPU or GPU is too busy to update the mouse.

Reproduction Steps
add one instrument track with some midi info for a kontakt library.
add one midi track for same instrument to use for cc info.
add a linear cc curve from 0 to 128 over several bars.
play midi data and move mouse
mouse will move jerkily

System Specs
I have a high end computer with AMD 16 cores and Nvidea Gforce RTX 2080 Ti.

Anybody had similar symptoms? Any idea what this could be?
It is not possible to work like this.

Related to Cubase 12 Mouse issues

With the Nvidea it is best to avoid the gaming drivers and just use their basic driver for audio work. I think (but not sure) it’s because both the gaming stuff & Cubase want realtime control and keep fighting each other for it.

1 Like

What is a basic driver? Do you mean the one from Microsoft?
Is this your experience? Is there an official info from Steinberg about this?
Unfortunately I also use the PC for gaming.
Switching video drivers all the time is not a solution.
I will try it however to pinpoint the issue.

As raino says , if you want to use Cubase properly you need to weigh up what’s more important , your DAW or your gaming because Cubase and Nvidia requires just the basic not frills driver , no experience , no digital audio driver , no 3d driver , just the STUDIO display driver . This is how it is im afraid so you need to work out what’s more important , gaming or audio related works

Thanks Raino and Highly-Controversial,
Never thought that it might be a GPU driver issue.
But, it is not that easy.
I had to install a very old Nvidia studio driver for a smooth experience.
The one that Windows installs automatically.
The latest studio driver also causes flickering and jerky mouse movements.

Following is my bloody path to the truth:
I had the latest nvidia gaming driver including nvidia experience installed.
Flickering and jerky mouse movement.
Read your answer.

  1. Removed usb driver.
    Flickering and jerky mouse movement.
  2. Removed hd audio driver
    Flickering and jerky mouse movement.
  3. Disable all gforce experience game overlays
    Flickering and jerky mouse movement.
  4. Changed power plan to AMD Ryzen high performance
    Flickering and jerky mouse movement.
  5. Removed nvidia experience
    Flickering and jerky mouse movement.
  6. Removed rtx gaming driver (using microsoft default and then automatically updated to nvidia studio driver (456.71))
    Smooth experience. :grinning:
    First time in months a smooth Cubase 12 experience.
    The difference to before is huge.
  7. Installed latest studio driver (537.58) with nvidia experience
    Flickering and jerky mouse movement. :rage:
  8. Removed nvidia experience
    Flickering and jerky mouse movement.
  9. Removed nvidia graphics driver (using microsoft default)
    After booting Nvidia studio driver (456.71) installed automatically.
    Smooth Cubase 12 experience. :smile:

What driver versions are you successfully using?

I will wait for your comment and then open a bug for Steinberg.
Working with Cubase 12 should not force me to install old drivers.
This driver is from 2020.10.20.

With this driver I cannot play Starfield. :angry:
Steam will not allow starting the game.

Already had 2 system crashes with this driver. Seems that even browsing in the internet is not stable. Probably too old?

Have you been into the Nvidia control panel and set the driver on Preferred max performance ?

Just tried that.
Change Power management mode in Nvidia Console Panel from Optimal Power to Prefer maximum performance.
Flickering and jerky mouse movement.
rebooted the PC.
Smooth Cubase 12 experience.

But what does this do?

I noticed before that GPU-Z tool showed very low GPU Clock, sporadically going up.
Now with Prefer maximum performance GPU clock is much higher.

Nvidia driver seems to have difficulties to detect that Cubase needs more Clock speed.

Thanks @Highly-Controversial!

Umm don’t know about that , all i know is about the main triangle of Latency interrupts .
Audio demands as least interrupts on the circuit as possible for low latency and if you have one piece of hardware causing a bottleneck then it creates Latency and DPC spikes , jitter and what not, so having all the components set to their Max removes and chance of bottlenecking at the components , this is how it is for audio , you need a super fast round trip with data for everything to run smoothly

Here is what’s working fine for me - which may or may not be the latest, but it’s close.


The basic problem is that both the gaming driver & Cubase think that they should have first dibs on using CPU cycles. The symptom you’re seeing is with your mouse, but it can also show up in a lot of different ways, audio glitching being a biggie. And issues can occur for any DAW.

Besides being in conflict to consume resources they also have intrinsically different priorities. A DAW is going to prioritize audio over video because you’d rather have the audio play smoothly and the playback cursor freeze instead of the cursor keeps moving but the audio clicks & pops. But the gaming driver is going to prioritize video over audio.

It’s basically a too many cooks in the kitchen problem.

I have this one in my dev pc and works as it should too. Note that the month is 8 in reality.

Exactly this. In July I did have problems with Cubase and nVidia and after a while I realised I had to disable the gaming mode, and since that day I have a smooth experience even at the dev pc.

I tried everything out that you all told me and used GPU-Z tool to figure out what is actually doing what.
Result can be found at: [FIXED] Cubase jerky mouse movement and GUI flickering