Disabled midi tracks lose midi send output routing


I’ve been experimenting with disabled midi tracks (as a visual guide to instruments that are disabled in Vienna Ensemble Pro). I’ve noticed that midi tracks lose the output routing of their midi sends when re-enabled after a few minutes of being disabled. If I disable and immediately re-enable the midi tracks the output routing is preserved, however if leave the midi tracks disabled for a few minutes the output routing is lost upon re-enabling.

Steps to replicate:

  1. Empty Project
  2. Create New Midi track
  3. Insert ‘transformer’ on midi send slot 1, route output to a midi port, set ‘midi send channel’ to ‘all’
  4. Disable Midi track
  5. Create Another Midi track with identical midi send setup and disable
  6. Wait 5 mins
  7. Re-enable Midi tracks —> midi send output routing is lost.

SPECS: Cubase 9.5.10 Build 79, Windows 10

This is pretty annoying as midi sends with transformers are a core part of my template setup.

Any possible solutions?



Is there necessary create another MIDI track with the same settings? I’d it necessary to wait? What happens if you disable and re-enable the MIDI track immediately?

Could you try in Safe Start Mode?


Is there necessary create another MIDI track with the same settings

No. Just tested with a blank project and adding a single midi track and the same issue occurs.

I’d it necessary to wait? What happens if you disable and re-enable the MIDI track immediately?

Yes it only seems to happen after the midi track has been disabled for a few minutes (approx 5 minutes, sometimes longer). If I disable and re-enable the MIDI track immediately then the midi send output routing is preserved correctly.

Could you try in Safe Start Mode?

Have just tried in Safe Start Mode with preferences disabled and am getting exactly the same issue.

Incidentally, the problem only seems to apply to midi send output routing - the main output routing of the midi track itself is preserved correctly upon re-enabling.


I will try to reproduce this on Monday.

The waiting time… Do you operate Cubase? Or is it OK just leave Cubase alone and wait?

The waiting time… Do you operate Cubase? Or is it OK just leave Cubase alone and wait?

It doesn’t seems to make a difference whether or not ive been operating Cubase during the wait. To be honest i’m not even sure that the wait is the cause - i’ve just managed to reproduce the bug by repeatedly disabling and re-enabling the midi track fairly quickly. Seems quite erratic. The only consistent pattern i’ve noticed is that right before the midi track fails to recall its output settings the mouse cursor briefly changes from a pointer to a loading wheel

Further point of note: issue is present with all midi outputs, so it’s not specific to one device.

I was able to reproduce it this way:

  1. Add a MIDI Track with MIDI Send, routed to any MIDI Port.
  2. Disable MIDI Track.
  3. Create another empty project, activate it.
  4. Go back to the original project, activate it.
  5. Enable the MIDI track.
    => The MIDI Send Port is set to Not Connected.

Reported to Steinberg.

Many thanks for corroborating. I’m fairly certain that the output routing gets lost even without activating another project and re-activating, but this may be the underlying culprit.


I’m new to bug reporting in Cubase - should I file a support ticket as well? or do you have a ticket ID or something I could follow?

It’s reported in the internal system as CAN-13635.

Apparently this will be fixed in 9.5.30

Has it been fixed? I also have set up my template in a way, so that there is a send with a defined port setting on each midi track. I use this to report to lemur app which track is selected. If you have a big number of midi tracks with cc information on them in the beginning, it is absolutely crucial to disable unused midi tracks. However, I have encountered the same problem: the midi port settings are not saved for a disabled instrument. Does this work now? I cannot see it mentioned in the 9.5.3 Version History…

I was sent the following message a while back:

‘The Cubase Pro 9.5.21 has solved a MIDI issue which closes your problem. However, I would inform you that “MIDI Sends port becomes Not connected” bur report will be solved with the Cubase pro 9.5.30. I cannot add further details at the moment’

However it doesn’t seem to have been fixed in 9.5.30. Gonna follow this up


I’m sorry, I can’t reproduce it anymore. It works to me, here with Cubase 9.5.30.

Actually, it still doe not work for me. I am on Cubase 9.5.4 (Mac OS 10.13.6). When I deactivate midi tracks with any midi send set to a specific midi port selected, save the project and reopen it, after enabling the same track, the midi port of that send is not connected …


You are right, this scenario is reproducible. And it’s also already reported to Steinberg (CAN-18936).

Btw, the project is already loaded with MIDI Port “Not Connected”.

Hey FriFlo,

The support team have finally acknowledged this exact issue (on October 26th) and have opened an internal report [CAN-18936] as “Disabled midi tracks lose midi send output routing”. Crazy to think that I first reported this issue in February 2018.

Hopefully they finally nip this in the bud

I actually reported that in the beginning of 2017, even earlier someone reported it with the track activation feature in Cubase 8, but as you can see, it did not raise a lot of interest … :wink:

Now, question of the day? Will this finally be resolved in a Cubase 9.5 update? Or does it work in Cubase 10? This latest Update is once again full of features that may be useful, but are not quite on my priority list. If at least this could be resolved, I might update, but otherwise I am quite annoyed by the endless stream of new features being implemented while older stuff isn’t quite working as expected …

Sorry to resurrect a dead thread, but did this ever get resolved?

I’ve just built a new template, using track enabled/disabled status to control visibility so things don’t get overwhelming. I also have a midi send on all my channels which is routing some auto-switching stuff to Lemur. Cubase loses the routing for this when the track is disabled (it seems to only be affected when the track is disabled for a while - God knows how long it takes for the routing to get lost).

Any workarounds for this? It’s definitely a bug, and like the last poster I wish Steinberg would actually pay some attention to fixing their bugs, instead of releasing shiny new toys.

Cheers, and again sorry to drag up an old thread, but this is an old issue…