Feature Request: ReWire/MTC

I got the trial version of Dorico Pro and was primed to buy it to replace Finale which I have been using since the '90s, but then I realized I can’t figure out how to sync it up with my DAW which is part of my workflow with Finale for synchronizing to picture. Is there a way to synchronize music I am writing using Doric to picture at all? I have been using ReWire and that served my purpose well.

Hi, welcome to the forum. Yes, Dorico allows you to import video directly into your project and score to that. No need for Rewire. https://m.youtube.com/watch?v=ZzehGY6AsYM

1 Like

Aha! My bad. Thank you – can’t wait to see how this works!
Edit: Thanks for the link! This is much better than what I was doing before!

Another request here for MTC sync. I’m running Dorico 3.5 trial to potentially move from Finale, which I routinely sync to Logic using MTC across the MacOS built-in inter-app MIDI, which is very easy. This is a must for me and seems to be the only thing stopping me moving to Dorico for all scoring work.

Welcome to the forum, @Smaug. This is definitely something we are planning to add in a future version, though I cannot say for sure at this point when it will be added, as we need to coordinate with our colleagues in Hamburg to work on the implementation on the audio engine side as well as our own team working on the Dorico side.


I found this TXL Timecode plugin and it seems to work in Dorico.

  1. Set up a virtual MIDI port.
  2. Load it in Dorico’s Instrument Rack in the play tab and set it to send the time code over your virtual port.
  3. Launch the MTC DAW or other software you want synced with Dorico and have it slave to the MTC coming over your virtual port.
1 Like

This is mostly brilliant!! Virtual Starbucks all around. Thank you Brian. It so far works quite well between Dorico and Studio One, though there is one not so obvious thing to me that someone else might have an answer for?

It syncs the DAW and Dorico, allows you to playback from any arbitrary point and be in sync. But press the record Button in Dorico doesn’t start recording in the DAW. What you seem to have to do is start Playback in Dorico and then hit record in the DAW to capture something. So you need to give yourself enough time in Dorico to do that. You don’t have to time your button presses exactly or anything (sync is still good,) but just give yourself enough time to get record enabled before you get to the part(s) you want to capture permanently in the DAW.

So I will appreciate a more complete solution from Steinberg when it gets here. But this is still kind of transformative to my workflow.


I first arm tracks for recording in Cubase and tap the record button in Cubase (which does nothing but light up and wait for time code to start coming in), then just hit ‘play’ in Dorico.

I use 3 screens, so it’s not a big deal for me. It kinda makes sense to me that whatever I want to record in Cubase…I’d need to arm and set things there precisely as desired first.

Don’t forget that you can also export a master track from Dorico to import into the DAW project as well. While it’s not what you want your DAW using to drive the transport, It may well come in handy to get your DAW’s visual grid and all set up in a way that’s pretty close to what Dorico is playing.

Yeah, on Studio One, hitting the record button starts the Studio One transport, and out of all of the nice options I don’t see a way to tell it just to arm.

Does the S1 transport take off of its own? Seems to me it should just ‘wait’ until some time code is coming in. No TC, the transport should NOT be moving.

For me I first arm the track(s) I want recording, then click record on the main transport bar. Under his own clock, Cubase would normally do a ‘count in’ and then start recording at this point; however, since it’s in ‘slave mode’, it just sits there waiting. I set the playhead in Dorico where I want it to start and tap play. So far at least…Cubase locks up and begins recording at the position that it should.

Rendering Dorico’s output isn’t how I’d normally use the combo really…just testing a bit at this point.

Thankfully Dorico does offer a floating transport bar that can be pulled to a more handy location to get the ball rolling, so doing some analog tracking and keeping it in sync is at least possible now.

Definitely takes off on its own. I also tried options like auto-punch for a certain region but no dice. Auto punch only takes effect when you press record on the transport - and that still takes off like a rabbit. I agree with you FWIW. Reaper is just as you say, and Pro Tools too as far as I recall.

Interesting. Might be some settings somewhere in S1. Could it be using it’s own clock, but just getting MMC to ‘start/stop’ or something? I’m baffled at how the transport could track in slave mode if there’s not time code coming in. Maybe some kind of flag in there to disable that behavior?

I did read appropriate sections in the fabulous manual a few more times, but no answers popped out. Not the end of the world especially with the transport window as you mentioned.

Thank you for the heads up on this Brian…
I managed to get Dorico synced up with Logic using the IACBus on my Mac and this Timecode app - Wow, this is huge! Not having so much luck syncing to Cubase, but I must be doing something wrong…I need to play around with it a bit more. For those people that miss REWIRE, this TXL Timecode app does work. You can demo it for free and it only costs 20euros. I also managed to record the output of Dorico into Logic by using a program from Rogue Amoeba called Loopback. This seemed to work well (after trying a few other audio routing apps) and with a bit of negative track delay I was able to hear that it all stayed in sync on playback. I did have to start Dorico a couple of bars early and then jump over to Logic and hit the record button. All in all this opens up a lot of possibilities.


Not sure if the Mac thing would be a huge difference, but here’s my method for syncing to Cubase on Windows. Works well here.

  1. In Dorcio load the TXL Timecode VST in the playtab’s Instrument rack. Set the Midi Output dropdown to the MIDI port you wish to send the timecode over. In my case I’ve used loopMIDI to set up a virtual port. I’ll leave everything else alone and just go with the defaults and deal with the offsets in my DAW.

  2. In Cubase’s top menu go to Transport/Project Synchronization Setup and establish these settings.

  3. This part is optional and one can kind of guess at it instead, but I do it to get an idea of exactly where on the timeline Dorico makes a sound and set my project time code offset accordingly.

I suspect the settings one needs can all change a bit if you change sample rates, or use a different audio device later, etc.

a. Use ASIOLink Pro (or Jack2, or reaStream, or an actual patch cord) to send Dorico’s audio output into the Cubase Mixer. I set up a track to record this input and arm it.

b. Make sure the Cubase Project Setup “Start Time” and “Display Time Offset” are set to zero to begin with. You can get there from the main menu: Project/Project Setup (Shift s).

c. Choose the timecode display option in the transport, DISABLE the tempo track, and click record on the Cubase transport. It turns red but nothing happens yet as the transport is waiting for some time code to tell it to move.

d. I play my Dorico score from the very beginning and let a few bars record in Cubase. Note that it won’t be at the start of the project at this time, but rather, several seconds in.

e. After stopping Dorico disable record on the Cubase Transport if it doesn’t happen by itself. If we don’t do this “Project Set Up” will be grayed out when we need it below.

f. In the Cubase project view select the event that just recorded in Cubase. Tap the l key so the Cubase cursor snaps to the beginning of the part.

g. Double click the cursor position to highlight it, and tap ctrl-c (to copy it into the text buffer).

h. In the Main Cubase Menu go to Project/Project Setup (Shift S).

i. Double click Project Start Time and tap ctrl v to paste in the cursor position.

Click OK
Cubase will ask if it should keep the event at the current time position.
Choose Yes.

At this point the transport is now in sync with Dorico.

Optionally you can set a time code offset in the Cubase Project Setup. In this example I will round up from the start time we pasted earlier to the nearest second so my first bar-line in Cubase shows as 00:00:00:00, and there’s a few frames of leadin for Dorico to get ramped up.

Click OK
This time when Cubase asks if it should move the event to the time position choose NO; because, we want it to stay right where it is, at the beginning of the project.

And now the Cubase transport is locked and loaded. If one wants the grid to kind of match up with what’s going on in Dorico in terms of bar sizes and whatnot, don’t forget that you can export a Master Track in MIDI format from Dorico, and import it into Cubase. Just remember disable the Tempo track after importing it so the transport stays locked up with the time code.


Thank you very much, Brian. I will experiment and report back!

I have Dorico and Cubase synced up perfectly - Thanks Brian - and using a Mac program called Loopback from Rogue Amoeba I am able to record audio from Dorico into Cubase with virtually no latency. It should be possible to work successfully with both programs together - I will have to try it in a real world project now, but essentially, it looks good!


Please tell if you face any problems or just how the workflow turned out to be like!

I tried today syncing cubase and dorico - it works very well!

For MIDI routing from dorico to cubase, I used macs own AUDIO-MIDI Studio. In there, you have to create a midi port by double clicking the red thing in the top left corner:

For me, the difference in timecode was roughly 20 seconds. I wonder where this difference comes from, it seems that dorico and the TXL Timecode -plugin have different timecodes unless it is manually corrected.

For me it was sort of a first love elation, but I feel as if I spoke too soon in this thread. It does work as advertised so can’t complain about the product. But alas, once past the first experiments with a couple of instruments - I’ve found that the load on my machine is (perhaps obviously) much higher that running Dorico alone, which means the sound devolves into crackles and pauses that much faster.

I might find use for it? But because offline audio exports from Dorico are always artifact free, I find it much more useful to build a high level sketch first, then work on certain parts or section at a time, export as audio and import a “video” of my current progress into Dorico as I work on remaining sections. I have hopes that version 4 will have made the on/off switches for instruments in the play tab a little more finished and consistent in their display.