option+shift B does not write B in the octave above

On a Mac, as I try to input notes with octave jumps, I cannot get option+shift B to input a B in the octave above.


Robby

Try option+command+up/down arrow after you’ve entered the note.

That works. But with every other note, option+shift inputs the note in the octave above. It’s just that the B doesn’t work.

Robby

You are also right. My question is: where did you see option+shift+note letter does octave note entry?

It seems that Shift+Alt+B is considered a dead key (it produces “ı”, which is the main body of a lower-case “i” without its dot). We’ll try to fix this.

dbudde,

I saw it another it in another forum topic, that you can input octave changes before (rather than after) note input.

Robby

I forgot to mention, I noticed when you aren’t in input mode, shift+alt+B enables insert mode.

Actually ⇧⌥B on Mac is not a dead key; ı (dotless i) is a letter in Turkish. It doesn’t take any further keystrokes to complete the input.

I think Daniel meant “dead key” as in it doesn’t do as expected. Its use in this context doesn’t work as it possibly should.

In write mode, if you are going between octave Cs, input one C, then hit Shift+option+C it will add the C in the octave above, hitting Control C (the actual Control key on Mac), will add the next C note in the octave below. It’s easier than having to input the note, then having to change octave after the fact. However, in this particular case, the shift+option+B does create the character you mentioned and therefore does not input the B in the octave above.

Robby

Please fix this problem. I see that it is not yet solved. I input notes very weekly via computer keyboard but with B if I choose another octave it doesn’t work so I have to use command alt arrow up or down to repair. Thanks!

I had a similar problem with alt-shift-c.
https://www.steinberg.net/forums/viewtopic.php?f=246&t=151838

It was my graphics card that was grabbing the keystroke.

The problem with Shift+Alt+B is a bug in the underlying Qt framework that we have reported to their developers, but which has not yet been fixed. It should be possible to assign a command to this combination, but it is not at present because Qt considers it an ambiguous combination.

Any progress on this? I’m suddenly having problems inputting with this note, which is strange becasuse I don’t think I had this issue in previous projects. I’ve tried restarting Dorico and my computer several times now.

The same happens to me with C instead of B (Spanish layout)

There’s no news on this problem, I’m afraid; the underlying problem in the Qt framework is still there.

1 Like

I’ve been having this annoying little problem for a while too, and finally decided to make a very easy little workaround. I just put a Dorico-specific command into BetterTouchTool which tells it to activate a “B” keystroke followed by a CMD+Alt+Arrow-Up keystroke and I bound it to the Shift-Alt-B shortcut.

I’ve set ‘m’ and ‘k’ for next note below or above.
Just as easy as option-shift.

I had the same problem.

I just noticed this and found the topic. I really like the control key function (single key) that takes notes to the lower octave - and would prefer an analogue that uses a single key to write notes in an upper octave. I find option shift + note is ergonomically awkward (note - I’m doing with move with my left hand). In write mode with the caret activated would it be possible to have the higher octave function with just one modifier key? (shift, option or command + note name)

You can certainly go through the Key Commands page of Preferences and add your own shortcuts for these note input features if you wish.

1 Like