Recording Pitch Bend comes out wrong

When recording pitch bend data in C13, it sounds all wrong.
It removes or simplifies the curve so much that it sounds like it’s pitching down and detunes for the entire bar.

Where it should have been something more like this:

Hi,

To me, it looks like the reuction plays it’s role here. Is it the same, if you set the Type of New Controller events to Step, please?

Setting the controllers to Step, works and sounds as it should, It is only when recording with Jumps (which is now the default) that things get messed up.

It is definitely the reduction that it’s being a bit extreme and not considering that pitch bend it’s returing to it’s default state and shouldn’t ramp forward.

It is very inpractical because the jump/step setting is very hidden in a menu and there is no button (that I could find) to easily switch between the modes.

The lanes also won’t remeber whther to record with steps or jumps, meaning I cannot record modulation with jumps and pitch bend with steps because the setting is global and aplies to all lanes.

Well, the problem is even worse, because after recording pitch bend with steps, I recoded some other automation with jumps and it simplified all my pitch bend steps in a completely unexpected and destroying way.

Before:

After recording some modulation:

Hi,

Reported to Steinberg. Thank you.

1 Like

If it helps a bit more, I think the issue came out because when I was playing with this, I was using the MiniLab3 from Arturia, where the pitch bend is this sort of pressure bar and can jump to any place anytime.

But these type of controllers are very common nowadays, and there might need to be a threshold limit where the automation shouldn’t simplify but jump.

I also noticed that for the sustain pedal (CC64), the simplification is dissabled and that makes a lot of sense, but maybe these things should be configurable somehow.

1 Like

Hi,

Every PitchBend wheel/joystick has a mechanism to return to the 0 automatically. So it’s the case of all PitchBands.

Yes, there are some MIDI CCs, which always record in the Step mode. These are the switchers. Apart from CC64, it’s also Program Change MSB/LSB (CC0 & 32), RPN and NRPN MSB & LSB, etc.

1 Like

Hi! I experienced the same problem in Cubase 13 Pro. The Pitch Bend is recorded but I have the same issue as Ariel. I feel confused! I cannot continue using Cubase 13 right now as it doesn’t feel professional at all. Cubase 12 Pro was working fine. I hope all bugs will be fixed soon. Thank you!

1 Like

Hi, I have the same problem here,pitchbend recording in 12 works flawless
In 13 with the same instrument ( The Cherryaudio dco 106 )I have the same problem that you can see above.
Pitchbend won’t reset to zero correctly.

I hope this can be fixed in the next patch or update !

1 Like

Hi,

Set the MIDI CCs from Ramp to Jump, please.

Hi,
Not fixed yet in 13.0.30

regards, Alex

Can you clarify what you mean by this, because to my knowledge, CC64 (Sustain Pedal) is a continuous controller just like CC1 (Modulation Wheel) for example and not an on/off switch.

Hi,

You are right CC64 is the very same Continuous Controller, as any other.But from the praxis, it’s rarely used as a real continuous data, as it most sends just 0 or 127. Myself, I own a digital piano with 6 levels of Sustain, but mostly, it’s not the case.

And the up/down time for the Sustain is mostly very short. So it behaves as switcher in most cases. Therefore it as been decided to handle it as a switcher.

Same as MIDI CC0/32 are very same Continuous Controller. But they are handled as switchers, becuase they switch the Banks.

I might have to double check, but my Yamaha digital piano from what I remember, produces CC64 continuously from 0 to 127.

It’s not the transition from fully down to fully up that the reason for full range CC64 exists, it is to be able to reproduce half-pedal states where the sustain/damper pedal is only pressed down partially. The instrument must of course support this behavior, but many piano VSTis and most digital pianos do.
Half-pedal is a common technique in classical piano playing.

Hi,

Cubase doesn’t prevent this at all. Cubase records and plays back all data. It just doesn’t reduce the data to the ramp.

I’m having the same pitch bend issue. After updating to Cubase 13, I sound like an amateur keyboardist when it comes to pitch bend. The pitch bend simply does not reset to 0. I’ve tried using 3 different keyboards and get the same results. I’ve been using Cubase for 2 decades and have never had this issue until now and this is making Cubase unusable for creating tracks live. (I can always go through the tedious process of fixing it in post for non-live situations.) Has anyone heard back from Steinberg regarding this issue?

Hi and welcome to the forum,

I’m not with Cubase at this moment, but could you please try… On the MIDI/Instrument track add a MIDI Part. Open the Key Editor and change the Ramp mode to the Step mode for the Pitch Bend. Close the Key Editor.

Hopefully this setting is going to be applied for the whole track, not just the given MIDI Part.

Thank you. It actually works. I would still like to see Ramp Mode work properly, but this is definitely a workaround I can implement. I’ll just save this setting in my template and forget it. Thanks again - You saved me lol.

1 Like