Seriously Dangerous Bug

I wish to warn of a SERIOUS bug in Dorico 4.2, running on Mac OS Monterey 12.6

Using Cmd-Z as an Undo shortcut, actually starts behaving as a Select All shortcut.
If you do not spot it in time, the next command will alter EVERYTHING in your score, and give you NO option to undo the untold damage.

This bug has just kindly donated me hours of work to do.

This needs fixing quickly.

1 Like

Welcome to the forum @user342

Does this happen frequently to you? Could you describe the steps involved to reproduce this?

And there’s definitely no ‘accidental’ touching CMD+A instead when this ‘Select All’ happens…? They’re both placed very close on the keyboard… Just saying…

Apologies if I’m mistaken that CMD+A is a standard ‘Select All’ key stroke on Macs (Windows user here)… Or you’re running a non-standard keyboard layout…

This is true. Though, if it was an accidental hit then you should reliably be able to undo it.

This has been reported before by several other users, yes.

1 Like

Ah yes, of course… :wink: Let’s see…

Ok, interesting… thanks

You should be able to recover one of the auto-save files, so at the worst, you would lose only a few minutes.
If you have Time Machine running, you’ll also have backup copies within an hour.

1 Like

For me, Dropbox with version history has saved my bacon many times.

1 Like

Thanks for the encouragement everybody. The only other programs running were Mail and Safari.
I was doing a lot of breaking two-voice chords into separate voices for a choral piece, which was a new task for me, but it was going well enough, using context menus and the “V” command.
I had been noting that CMD Z was acting as a CMD A for a number of times, and stupidly continued editing, without saving and quitting to reset Dorico. As I was flipping note tails on second voices a lot, it only took one un-noticed CMD-Z, followed by a “F” commend, to flip my entire score into an inverted mess. Steep learning curve, for me, but evidently a job in-hand for Steinberg, as others seem to be experiencing the same potentially destructive bug. To be absolutely clear on this, the bug eliminates the undo function, and makes it unavailable (other than the ability to undo the Select All command). Is it time to incorporate an Undo/Edit History function? Keep an eye on this one!

Not that the key-combo error doesn’t need to be fixed, but does the Edit > Undo menu option still work as intended as a way to rectify the key-combo results?

1 Like

No. That is the nub of the problem. It only offers to undo the Select All, as the single option.
After you select that option in the edit menu, there are no further options available (98% sure of that). That is why it is potentially so destructive. A reboot sorted the problem and it has, so far, not returned. If it recurs, I will be more attentive to the behaviours, and report back. Puma 0382 says it has been reported before. I shall see can I locate any of those earlier reports. They might jog a memory.

Forgot to mention that I am using a new iMac, based on the M1 chip, with 16GB of memory.
The demands of Dorico, forced this serious upgrade, as it was like a slug on a 2016 Macbook Pro, and took a very long time to boot up.

I’ve reported this same bug when using an Intel MacBook Pro. The problem is that it goes away when the file is reopened (or Dorico is reopened), which makes it very difficult for the developers to pin down the problem.

This bug has indeed been reported before, e.g. here:

Although we have never been able to reproduce this problem reliably in-house, we made some changes in Dorico 4.2 that we hoped would have ameliorated the problem. I’m sorry to hear that it has tripped you up and cost you some time.

Thanks Daniel. At least I have now learned how to work fast, with the change to V4.2! I was struggling to unlearn other programs I guess, and I found the logic of the earlier versions not so instinctive for my needs. I have finally worked out what makes you guys tick! The repair was not so time-consuming, as it turned out. It made me aware of some new techniques, as a bonus. Am I correct in thinking that the bug:-- “It only offers to undo the Select All, as the single option.
After you select that option in the edit menu, there are no further options available”? I am pretty sure that was the bind I was in.

This Undo bug happened on Windows machine too and also cannot reproduce. But it seems that in 4.2 it is fixed, at least I don’t remember it happened in this build.

But while testing this behavior, I solved previous problem I had with JumpBar. I will search my post and write there. It’s really strange behavior.

You should be able to recover most of your work from one of the automatic backups.

+1 just happened to me

This also happened to me as well last week - but I was heads down composing and just worked around it.
I was unable to repro later on.