SOLO and MUTE shouldn't send MIDI on/off to VST Instrument Tracks

Currently SOLO and (presumably) MUTE operations are PRE-instrument: based on my findings I have reasons to believe that when performing solo and mute operations on tracks Cubase CUTS the midi communication between the track and the midi instrument. Arguably it sends MIDI on/off to virtual instrument, I cannot for sure say this because there is no way to monitor exactly what happens under the hood (not even with midi monitoring)
I made a video so you can hear the acoustic implications of this (forgive the potato sound quality and the typing captioning aha)

I think ultimately SOLO and MUTES operations should not affect what the MIDI to virtual instruments, let’s say you wanna solo a long evolving sample patch, whenever you solo and mute anything in your session you will be retriggering that sample over and over again.
If you wanna try this at home here is the repro steps
REPRO STEPS:

  1. Create an Instrument track
  2. Draw a LONG midi note, like 20 bars
  3. instantiate your virtual instrument, For the sake of testing you should use something that has a clear and defined initial envelope or an LFO that re-triggers upon receiving MIDI note on.
    4)Press play
  4. while playback is running toggle between MUTE and SOLO on the track
  5. BUG (?) -----> you will hear the instrument getting re-triggered over and over again even tho the midi note on the track is a long 20 bar contiguous note
1 Like

Yeyo
As I understand the previous video might be hard to follow I made a TLDR video of this strange behavior here it is enjoy

UPDATE: you don’t have to solo and them mute can just mute and unmute and you will hear retriggering stuff. byebye

What you show in the first video when clicking Solo on the Folder Track, is the actual issue caused by MIDI Chase.
Since the MIDI Track is already playing, toggling Solo is not expected to retrigger the notes, but it still does.
That is the only real issue and it only happens with Folder Tracks.

What you show in the second video is the expected behavior of MIDI Note Chase when you get out of the Muted state.

You can configure MIDI Chase in the Preferences. MIDI Chase reads the preceding MIDI data in order to retrigger the notes the cursor is currently on when you get out of the Muted state. This is especially useful on slow pads and strings.
When MIDI Chase is Disabled, the notes won’t be retriggered anymore, but they will stay silent until the next upcoming notes are read.

Also, I’m not sure you’re constantly hitting the Mute and Solo buttons that fast when listening to your track, are you? If you feel better with it disabled then just do it, just that you’ll hear very long silences on some tracks which isn’t great either.
The issue with pressing Solo on the Folder Track has been reported already.

This is the issue 4 in the issues list.

2 Likes

I see what you are saying here, disabling chase will causes long silence, however I simply don’t think that MUTE or SOLO operation should influence MIDI in the first place (unless for a MIDI track but most certainly not for Instrument Track).
Try this on any other DAW and you will see that this doesn’t happen. MUTE or SOLO operation (for instrument tracks) should be at post-fader audio LEVEL not Pre-MIDI level. Hope I am making sense.

A MIDI Track or an Instrument Track is exactly the same thing.
Both are MIDI Tracks, just like the Sampler Track.

It actually does both. When you use Mute and Solo on a Instrument Track, it applies to both the MIDI data AND the audio channel. How do you think MIDI Chase would work then ?

Maybe that’s the problem, we have encountered this issue many times , MIDI and Instrument Tracks are the same in topology and in the way Cubase manages them but should not be acting the same. After all, if you think about some very basic logic one might argue that if MIDI and Instrument Track are the same thing then why this differentiation even exist? If MIDI and Instrument tracks are “the same thing” then why do I have the option to create an instrument track instead of a MIDI track?
You see it doesn’t make sense.
Again I understand why this happens, I’ve been using cubase since early 2000 so I am aware that the instrument track is nothing more than a MIDI track that sends midi to a vsti instrument rack automatically. Do I think this stuff make sense in 2022? Absolutely not .

Yea I’m actually not talking about MIDI Chase AT ALL. midi Chase feature was put in place for a specific task that has very little to do with muting or soloing a track…I am talking about AUDIO FEED here. No midi, forget the midi.
MUTE or SOLO operation should interact on the AUDIO output of the track. On an instrument track it should mute the AUDIO of the vsti instrument rack that midi track is connected to but should NOT cut MIDI communication. Do you see what I mean?
Please investigate a little bit in other DAWs, like for example ProTools you will see what I mean.
Again forget the midi, I’m talking about AUDIO here.

So now you’re having an issue with the audio part ? Please elaborate.

I knew this was gonna be a difficult topic to unravel…I made a video comparison between Cubase and ProTools, let me know if this is clear…

The bottom line is:
MIDI communication between MIDI track and Virtual Instrument should NOT BE interrupted by MUTE or SOLO operations (regardless of MIDI Chase setting)
MUTE or SOLO operation should be restricted to AUDIO feed. MUTE operation for example should CUT the AUDIO FEED of the virtual instrument but NOT interrupt or alter midi feed to virtual instruments.

Remember, this behavior is questionable, regardless of the chase settings…

2 Likes

This was actually the issue all along. Please read the OT again. let’s not get confused by MIDI chase, that s a different thing all together.

Dude can you stop beating around the bush ?
In the Original Post the only thing you do is talking about MIDI.
You even got to the conclusion all by yourself :

I don’t know how to explain it better but when the MIDI track is Muted it simply stops sending data to the Instrument.

As I said, an Instrument Track is just a MIDI Track routed to a virtual instrument, so as I said just above, muting the track will stop it from emitting MIDI.

MIDI Chase causes the MIDI notes to retrigger whenever the MIDI Track gets unmuted, and MIDI Chase exists because of the above reason.

WHY ? For what reason do you want it to work in a different way ?

I don’t think I can explain this any better than what I have done so far. Forgive me if the message doesn’t come across. I think ultimately if you don’t write music as a job you will never relate to this hence never understand it.

Sorry if I fail to understand what would be the purpose of not muting MIDI data.
But YOU don’t understand that even if the MIDI data wasn’t muted, the MIDI Chase would still retrigger the notes ! Because it is simply designed to do that !
Maybe @steve could give us his opinion on the subject. :man_shrugging:

Well don’t get me wrong, the main subject is that you hear the notes retrigger when you press Mute and Solo. But now this is not the case anymore ? You even made videos of it.

as I mentioned before, this topic is not about midi chase. You threw midi chase in the mix and I simply addressed the fact that midi chase is indeed not what I am talking about in the original topic. Let’s please forget about midi chase. It has nothing to do with this issue.

If MIDI data wasn’t muted and the instruments still playing in the background, just explain me how you would manage the CPU load on 30+ instruments ?

Yea in the video I also addressed how disengaging midi chase was not going to be a viable solution to my problem. Again I am begging you to disregard the midi chase status because it has indeed nothing to do with this topic…
What I am desperately trying to point out is that MUTE and SOLO operations on instrument tracks should not mute midi clips. No other daw does it so I don’t see why Cubase should.

Protools, Ableton, Bitwig and even Reaper to that very well. I don’t think processing power is the a valid point. here unfortunately, that would be true if instruments or plugins are active or inactive…I also think DSP processing and CPU loads is something that every vsti manufacture does differently, for example in certain samplers such as Kontakt you can set the library to stream from disk (DFD) or load the samples onto the RAM which has minimum effect on CPU processing…

1 Like

I strongly advice you to do your own testing on other DAWs and see what happens there, you seem like a very bright individual - I’ll be more than happy to read your findings on the matter (shoot me a DM!)

1 Like

Also, I’m sorry for pointing out the obvious:
If 30+ instruments are playing with no problem when no track is soloed or muted then why would it be an issue when one of them is soloed or muted?
Sorry this makes no sense
LOL

I’m trying to migrate from a long history of Logic to Cubase and I’ve been wondering the same thing.
It makes muting and unmuting arpeggiated synths a pain. Say you have an arpeggio playing where you have a bar long note. So when you unmute the track it is out of sync until the next bar.
I think Aulicon made their point very clearly and Louis_R had a hostile and defensive response.

2 Likes