WaveLab 11.1.20 Maintenance Update

Dear Forum members,

We have just released another maintenance update for WaveLab Pro, Elements and LE 11, version 11.1.20, as well as for WaveLab Cast, version 1.2.20.

This update resolves many critical issues across different areas of the applications. We strongly recommend installing this update to ensure that everything runs smoothly.

As always this update is available for download from the Steinberg website and via the Steinberg Download Assistant .

For detailed information, please refer to the corresponding version history.

All the best,


I am running Windows 10 Pro. I spent over a half hour with all kinds of “strange” or “unfathomable” messages before I could get the 11.2.20 update to install this morning. At one point it told me that my “computer is not authorized” and I would have to “authorize it” and at another juncture it said it had to download a new authorizer which took forever. It finally got installed but what a mess.

Who ever wrote the Steinberg authorizer needs to “field test” or “beta test” it more before asking people to use it. It is NOT “user friendly” nor is it ready for "prime time"IMHO.



Same here …

Same here as well. The license needs to be activated via the Steinberg License Manager. The one on the eLicenser no longer seems to be recognized. It’s the same with the recent migration of Groove Agent to the new licensing system.

Yep … GA5 also bunched.

Same here. After months of struggling with Cubase 12 masterpiece we have now WaveLab 11.1.20 not starting.

Thank you, Steinberg!

Tried to do this update twice through Download Manager … which gives the message that it’s updating (40 MB) but just hangs unresponsive until force quit through task manager. I lost confidence in the update and these posts have done nothing to restore it.


Trying to understand is this both a Windows and Mac OS problem?


regards S-EH

I’m on windows

hi Eugene, I assume you were using the license on the elicenser.

if so you should have a licence available in the Steinberg Activation Manager that should get you up and running again.

post a message in this thread

and I’ll give you a hand to get it sorted.

I used WL all day yesterday after all the hassles with getting it to accept the update. I have not turned on the computer yet today but I am really hoping that I have no further problems since I have a lot of work to get done. This has been a real mess.

One can only hope that someone higher up at Steinberg is aware of all the problems…and is kicking some butts to get it solved. This should NOT be happening.

Thomas, sounds like you had multiple issues - and I agree it’s not acceptable. If you got it working yesterday I’m confident you’ll have no further issues today - assuming SB don’t change something again ?

We trust SB to look after our licences and not remove access to them - looks like they failed in this instance…although still no official statement ?

I think for many of us there are workarounds to get stuff up and running but doesn’t inspire any confidence going forwards - especially as we were given no choice as the SAM autoupdates wether you want it to or not.

I think this only effects a small niche selection of the user base - but as more people have the SAM update forced on them I suspect we’ll see further fallout.

just remind me, what was it about the elicenser that was a problem :smiley:


I just installed Wavelab 11.1 pro update. Can I now deinstall Wavelab 10.0 ?



Yes. This won’t affect WaveLab 10. But run WaveLab 11 first, to get a chance to import WaveLab 10 settings.

I’m on Win11 Home 22H2, OS build 2261.755 here. I updated my elicenser (this was initiated by Steinberg when I downloaded the new WL version) and hit install from the Steinberg Download Assistant . The install was flawless, no hiccups.

I moved into Win11 expecting some issues but this has not been the case. Win11 is clearly a better OS than Win10 in my experience. Even my MIDI (via USB) keyboards perform better than they did in Win10 (Studio Logic and Roland).

As to GA5, not a problem here FWIW.

1 Like

the various licensing problems that have been reported only occur in very specific situations :slight_smile:

and yes, apart from the licensing issues, V11.1.20 works great :+1:

now where is my list of unimplemented feature requests ?

I´m trying to update to Wavelab elements 11.1.20 but every time I run the installer it suddenly closes without doing anything. I´ve try everything like update from elements 10 but always the same issue.
Sameone with this issue?
some suggestions to solve it?

Mac or Windows?