Cubase iC Pro 1.2.3 and Remote SKI 1.1 available (on sale until Jan 9, 2023 - ended)

I believe it reads 1.1.015. Is that the latest version?

Really glad to see the updates to iC Pro. This is an indispensable tool in my Cubase workflow! (macOS 12.6.2, iPad OS 16.2, Cubase Pro 12.0.52). The shortcuts buttons alone save me endless amounts of toil (I can only remember a limited number of keyboard shortcuts :smiley: ).

That said, I give the app 4 stars instead of 5 on the App Store for two reasons:

:point_up_2: this

and because the in-app help says under “Assigning Commands/Macros” that “You can export and import your templates with iTunes” but no further explanation is given, and there is nothing in the online manual about this. I have no ideas how to do export or import of the templates - is this even possible, or is this just some old text in the in-app help?

As for the magic keyboard trackpad, please please enable that if you can. It’s really annoying and confusing that you can’t click where the cursor is pointing, but have to touch the screen. The actual keyboard part works well, but I really wish the trackpad worked too.

Thanks for keeping this extremely useful app going.

Thanks @pumpichank!

1 Like

Hi all,

By accident, I’ve stumbled on this great unbiased review of Cubase iC Pro, which has been released one day ago.

If you’re unsure if Cubase iC Pro is for you, this review featuring all aspects from installing to using the app should answer your questions…

Stay safe,
enjoy your season holidays
& warm greetings


Hello, maybe this post from @KenD can help you:

1 Like

I have to say your rant seems a bit misplaced I think.

It’s not really Steinbergs fault that iOS is a closed system and with that the App Store is the only proper way to distribute apps to the iPad/iPhone. And yes then you need an Apple ID to use the App Store.

What a wonderful world it would be if we didn’t have to remember any accounts or passwords…

1 Like

Perhaps you’re right. I’ll give Tim Cook first thing in the morning. :smiley:

Look, sometimes there isn’t a ‘right person’ to complain to. Nevertheless, I think the issues I raised are, worth considering. Cheers.

Would it be possible to add names to the audio & midi files within Cubase IC Pro project window display please?

Hello Lars,
i did everything as intended.
My bonjour for windows is up to date
My SKY remote is on version (last update available.
It’s showing on studio config in my Cubase pro 12.0.52 build 396
When i try to connect by “http://cubase Ip adress:45000” it ends with an Error400.
nothing else.
i used Sky Remote for years in my setup and it doesnt work anymore from C12 update.
Please notice that it doesn’t work either with my cubase pro 11.0.41
Hope that those information help you (and me) to make it work again

You are not using the app but trying to browse to it. This no longer works and it wasn’t designed to do this. It was designed to work with the app.

Hi Lars!

  1. Download page says, SKI Windows installer is 845 MB, but in fact it’s just 6 MB.
  2. The pdf manual mentions - that’s a 404.
  3. Question: Does this new SKI installer include the iC Pro Android beta functionality from this page, so will it update to 1.1 without losing functionality, or is it forbidden to install 1.1 for people still using that?


best regards
and happy new year

Hello Lars,
I did everything as explained.
My Bonjour Print Services for Windows is up to date
My SKI remote is on version
SKI Remote is available in studio setup on Cubase pro 12.0.52 build 393
My Windows 10 Desktop (Cubase computer) is available in IC Pro but will not connect to my iPhone 13 Max(ios 16.2) or my iPad(iPadOS 16.2).
What to do? This app would really be helpful.

Do you have a firewall blocking it? When you installed Cubase and then the other elements did you agree to give them access? If not you may have to start again.

What if you put the ip address of your computer into ic pro? Still nothing?

Hi mkok,
Cubase 12 has access beyond the firewall. I have turned off Bluetooth - no change
I have created a new rule for UDP Port 5353 - nothing
Inputting the IP address manually - nothing

I don’t know then. I’m on win 11 now and it’s working ok. Win 10 should be the same.

When you mention allowing an app through the firewall, are you referring to Cubase 12, SKI Remote or Cubase IC Pro? I only see Cubase 12 in the list.

I know when I first started using it a few years ago I tried everything and then I reinstalled Cubase and accepted all the settings

Worth a try!

Am I missing something here, or is the timeline still in seconds as oppose to beats/bars? If this is the case, why?

Looks like a firewall blocking issue here, hope you’re able to resolve this!