Cubase Pro 11 Project Window and Key Editor Grid Issue caused by HiDPI

Hello team behind Cubase,
I would like to report a serious bug that I’m getting with Cubase Pro 11, which wasn’t in Cubase Pro 10.
Please, check the screenshot below:


As you can see the properly positioned darker grids (for new bar ) are enclosed in green, and those which are incorrect are enclosed in red. I’m having the very same issue with the grid lines in the Key Editor.
I have found that if I turn off the HiDPI function everything is fine. My DPI settings are set to 125% and without the HiDPI function Cubase looks blurry.
I hope you would do something in order to fix this problem! :slight_smile:

Best regards,
Thurisaz

1 Like

I have the exact same issue on my machine. Also since Cubase 11. I also tried changing the DPI setting to 150% in windows. The problem however, remains the same. Makes editing quite a bit harder, as you have to double check your grid position every time.

Has anyone with this problem opened a support ticket?

Have you eliminated prefs corruption as the culprit?

What do your systems have in common with each other that makes it happen for you, bit not on most other system setups?

@steve hello,
The post here is the “ticket” as a Bulgarian I don’t have opportunity to directly contact the Steinberg’s support team. I need first to contact the distributor here.
I have tried to trash the prefs ( Cubase_11 folder ), but this didn’t fix the problem. When you change the Project Area Background (as shown on the screenshot above) the bug appears again.
I don’t have this issue with any other app that supports HiDPI on my PC. Only Cubase has it.

Here is a screenshot from Dorico Pro 3.5 - Play Mode:

As you can see everything with the grids looks as expected. :slight_smile:
So, the problem isn’t caused by my system. My graphic card is Nvidia Quadro 4000, 2GB memory, I think more than enough HP Z820 Workstation, 2x 8-core Xeon E5-2670 @ 2.60 GHz
Windows Pro 10 1909 OS build 18363.535.
I hope this is enough helpful information! :slight_smile:

Best wishes,
Thurisaz

The fact it works (or doesn’t) in Dorico is immaterial, the two programs have different methods in regard to graphics. What’s needed from users is simple and specific info like you posted today. Also it might be relevant, so what monitor(s) are you using?

If others report some details maybe a pattern will emerge.

@steve,
Thank you for the reply! :slight_smile:
I’m using QuadHD Dell P2416D, 23.8 inches at 125% DPI.
If you need more information, let me know. :slight_smile:

Best wishes,
Thurisaz

@Mr.Harmony can you provide some details?

@steve,
Would be nice if you also check this topic which reveals similar and other HiDPI issues that various users experience.

You may ask the people to share more details about their systems. :slight_smile:

Best wishes,
Thurisaz

Hi, I’m just another random user and this is a wild guess, but I had weird graphic issues when I switched to a 4k screen with scaling enabled. It turned out that it was caused by the nvidia driver, which applies several filters not only on 3d video and games but also on certain desktop applications.

I disabled all anti-aliasing options and some strange sharpness filter for cubase in the nvidia system control (you can do that on application basis and keep your global config).

My problem where rendering artifacts all over the place though, I didn’t encounter the kind of strange lines thicknesses you got, so it’s maybe completely unrelated. It’s always good to eliminate the graphics driver as a cause though.

Best regards and good luck.

@Friede hello,
Thank you very much for your help! :slight_smile:
I’ve tried to “play” with the NVidia driver but it didn’t work. The problem still persist.

Best wishes,
Thurisaz

@Thurisaz Thanks for reporting and sorry about the late reply. I was sure I had answered this one already.

This is known issue due to the way we render those lines. Nothing to do with your GPU, hope you didn’t sell it meanwhile!

The bug is reported under the ID CAN-33417

2 Likes

@Armand hello,
Thank you very much for the reply! :slight_smile:
Still I don’t have plans to sell my graphic card. :slight_smile: I was sure that the issue is in Cubase waiting to be resolved.
I have other HiDPI compatible apps which work just perfect. :slight_smile:

BTW, there is one more HiDPI related BUG with the Auto Scroll > Stationary Cursor!
When HiDPI is activated in the Preferences and Stationary Cursor is selected, the Timeline doesn’t move smoothly as expected. When HiDPI is disabled the Timeline moves as expected.
I hope this also will be fixed! :slight_smile:

Thank you once more! :slight_smile:

Best regards,
Thurisaz

1 Like

Sorry for the late reply.
I was about to post some details about my machine, then I saw that @Armand already reported this as a known bug. In case any details from my end could still be helpful, just let me know, I’ll gladly help!

Thanks for your feedback.
By “not smoothly” I assume you mean that the vertical lines flicker due to constant width changes depending on where they are rendered on your screen, right?

@Armand hello,
Thank you for the reply! :slight_smile:
Yes, the timeline kind a flicker during the playback. Probably this would be fixed alongside with the problem. :slight_smile:

Best wishes,
Thurisaz

Is there any update on this?, the lines are all over the place, it’s barely impossible to know where the beats are :expressionless:


V11.0.10

Hello @arieln ,
Unfortunately still no any updates on this topic…

Greetings

We are experimenting with a few alternatives here. I cannot promise any milestone yet but we’re checking this out.