Elastique crackles/artifacts on audio playback in some cases

Hi!

Have some time for investigating into the problem.
There was officially confirmed issue on Cubase 9 [CAN-6011]
and there is old thread describing the problem: [CAN-6011] AudioWarp/Quantize glitches (Now reproducible!)
which is somewhat similar to mine.

So I am experience it with C11.0.30 and THERE IS (!) clicks & pops in exported (freezed) audio
This issue has absolutely random reproducibility (9 of 10 my tests it exists )
So there will be no steps to reproduce - Just hit play (could try cycle mode on/off)
(2 projects with freezed/unfreezed track attached)

That’s what I came up with.
I Have:

  • Brand new RME UCXII with latest FW & Drivers (had the same issue with my old RME UC)
    buffers are set to 256 samples which is ok (tried various settings - does not affect an issue)
  • Latest drivers for BIOS, chipset, graphic card etc (more specs in my profile)
  • Windows 10x64 Pro 20H2 with latest updates and highly optimized for working with audio
  • BIOS settings optimized (high performance, c-states disabled, hyper threading is set to off, EHCI hands off etc)
  • Dedicated SSDs for system/projects
  • No antivirus/windows protection software installed/used
  • Latest eLCC software installed
  • DPC Latency Mon - showing system is ready to work with realtime audio
    Additional info:
  • No CRC buffer errors (RME fireface settings dialog)
  • low CPU, low disk usage with this test project

What I have tried with no success:

  • Trashing Cubase preferences - no effect
  • Control room disable/enable - no effect
  • Generic ASIO drivers - no effect
  • ASIO driver/ASIO guard/multi processsing/audio buffers doesn’t affect anything regarding this issue too
  • changing USB ports/cables audio card/eLicencer - no effect
  • disabling WiFi/audio devices such as Behringer Xtouch mini controller - no effect

Elastique stretching algos + musical mode + transpose + hitpoints detect - thats what (my guess) more likely leads to an issue.
BTW all is ok when using Play tool (9) on this project :roll_eyes:
I even tried to reproduce this issue with the same audio file - no success! :exploding_head:

Can’t check this project on Cubase 8.5.2/9.0.20 unfortunately (there is hope it works ok there)
I would appreciate if someone could test it (on Cubase 11 too)
clicks.issues.zip (1.1 MB)

P.S.
I have huge 100+ tracks projects with heavy vst/vsti working like a charm but those occasional cases with only one crackling audio track without any effects on it are driving me mad.

kind regards, Alexander

What about updating to the latest version 11.0.41?

As far as I’m concerned there is no audio related fixes since 0.30 isn’t it?

But would be great if you can test it on .41 version

regards

I can’t say I’ve noticed this but my songs are up to about 40 tracks and I don’t freeze vst instruments. I just render when I e finished. By the sounds of it it could take some finding if it doesn’t happen all the time. If I get a chance tomorrow I’ll try and reproduce

1 Like

Just installed and tested .41 version - no luck :face_with_head_bandage:
same crackling

regards

@audiosnob … Just little bits of history repeating :grin:
But now it is one of my projects

regards

Ok.

I have installed Cubase 8.5 in VirtualBox (Win7x64 environment)
And make it work using generic VBox audio controller (Intel HD audio) with Asio4all driver.
Opened my project and… it crackles there too!
and no crackles with Play tool just like in С11.0.41 :face_with_monocle:

@Martin.Jirsak @system would you please look into this ?
(just check my test project for crackling issues actually)

regards

Well, well…

Come one, guys, do a proper Elastique implementation and let us automate the parameters.
Some of us are doing sound design from 9 to 5 and this is just embarrassing.

1 Like

Here on my system:
spikes.test.cpr - I dont get any glitching issues u described
spikes.freezed.cpr - here I have those glitches since audio is frozen.

When I freeze audio from spikes.test.cpr I got exact same glitches as in spikes.freezed.cpr
However if I do render in place or Audio - Bounce Selection I don’t get any glitches.

I experience those glitches often when I am doing a delicate and detailed manipulation which involves:

  1. Cross-fades
  2. Stretching in musical mode (Audio Warp)
  3. Free Warp
  4. Vari Audio

For example:
Combining Audio Warp and cross -fades(X) I got glitches depend of the position of cross-fades (or to be precise starting point of cross-fade)

When you dial those settings to some extend, Cubase gets unreliable and also depends of the combination of those 4 above.

I first encounter with these utter odd things 5 years ago when you duplicate 2 tracks, flip polarity on 1 track and move length extension by micro point and suddenly on some point 2 tracks don’t get null. To be more weird it is easily reproducible when you have tempo track in your project, but its also reproducible without tempo track too but just way way harder.
More info here: Tempo Track Null Test Bug?

So I assume that lot of things has to be rewritten from the ground in order to get this engine properly and stable (like you have in Reaper) as I work for 6h to 10h almost everyday on some detailed stuff that involves lot of processing as described I can clearly feel that unreliability which are not always straight forward and easy to reproduce.

My advise would be to find way around as from my “tempo track null test bug” thread I don’t cut section(which I want to emphasize) on duplicate track but rather automating volume when I want to be silent or emphasized.
-Avoid combining massive audio warp and pitch shifting (especially with formant algos) but rather do one by the time. First Warp/Bounce it, than pitch it etc.

As many times you across with these oddities you will get sense what is no! and what is no! no! and what is NO! NO! NO! NO! :joy:

Good Luck

2 Likes

Thank you for the extensive input!

Unfortunately, the workarounds you mentioned suit some enthusiast open-source software on Linux, not a pricey, 30+ years old behemoth of a DAW.

1 Like

@Grada Thanks for the info!
Just confirmed that my issue happens on several machines.

regards

That’s how it is unfortunately, I am not covering steinberg here but opposite I am agreeing that this should be more reliable. From long practice being enthusiastic about fixing stuff like these is often a rabbit pit and that “30+ years old” you mentioned is one of the reason why updates often brakes some things that in previous worked well and why sometimes it takes so long some stuff to get sorted out.

1 Like

Bump!

Same thing happening on Cubase 12.0.30 on MacBook Pro 16" M1 Max

Crossfades and Elastique = massive crackling / artifacts.
Also happens with Elastique time stretch combined with transpose.

Changing time stretch algorithm to Standard eliminates all artifacts.
Using Play tool also eliminates artifacts! :exploding_head:

1 Like