Enter Project Cursor Position [SHIFT + P] bug - Workaround

Since C10, many users are seeing a bug with SHIFT+P as reported in these threads;

https://www.steinberg.net/forums/viewtopic.php?f=286&t=166810
https://www.steinberg.net/forums/viewtopic.php?f=250&t=166078
https://www.steinberg.net/forums/viewtopic.php?f=286&t=162877

I just realized no one suggested a simple workaround (and actual cause) for this.
I know how annoying this is, I think most of you seeing this wants the old behaviour back instead of seeing the little window to enter a position and pressing enter twice.

You can work around this by using the following simple macro;

1.Transport - Panel [F2]
2.Transport - Panel [F2]
3.Transport - Enter Project Cursor position [SHIFT + P]

Assign this to [SHIFT+P] instead then it will feel like used to be.

By pressing [F2] twice, you can assure the transport panel is focused. And if the bar was closed, nothing will be affected.
Then by the last command - [SHIFT+P], it lets you enter the position directly to the panel.
The only side effect is that you lose focus from the last window you were working on, causes an unnecessary mouse click.
But somehow you will find this side effect isn’t very annoying, it feels almost transparent.

This problem happens when there is the transport bar [F2] shown on-screen and the transport window is not focused.
I.e. If you are using the new transport ‘zone’, you are not seeing it at all. Also if you opened the panel before entering [SHIFT+P], it works no problem.

These conditions made this bug a bit random to repro.
I guess that’s why no one wrote a solid repro steps and/or built the workaround above. I’d say this is a Level2 bug to nail. :slight_smile:

So please try. But as I would like this to be fixed, anyone finds this useful please reply to this thread to let
Steinberg know there are still users who prefer F2 transport instead of the transport zone, at least until the zone is implemented to all editor windows.

Cheers,

Takashi

I have another solution to this issue.
It’s much simpler, and involves no MACROS or reprogramming of default Key Commands.

Shift/P opens Project Cursor Position dialog.
Type in the required value.
Instead of single clicking, press the ENTER key twice (or double-click ENTER). This enters the value you typed in, and then closes the dialog box.

Ta-daaa…!

This leaves me wondering whether in fact this IS a bug, or by design. It gives you options.
Single click ENTER - leave the dialog open.
Double-click ENTER - close the dialog.

Thank you.

However the problem is the next time you press Shift+P and the window is already opened, the command won’t let you enter position and instead the window closes. The window is so small, you could easily forget wether it is opened or not. That result feels like if the KC works randomly which is very frustrating.

I also don’t like to build muscle memory to avoid a simple bug, then you’ll be frustrated again once it’s fixed.

Takashi

The problem with pressing enter twice is that if your are in the main (arrange?) window, then your sequence starts playing. Which is not always desirable. This is definitely a bug and I really wish Steinberg would fix it as it’s driving me crazy.

TakashiWatanabe I’ll try out your solution…

But still Steinberg please fix!

TakashiWatanabe, I can’t get your macro to work. Even with the transport panel open, when I hit enter project cursor position, it doesn’t use the transport panel window.

Yes this is a major bug, and just needs to be fixed. Please help Steinberg. I know several composers still just avoiding upgrading because of this issue. I being one of them.