Render in place incorrectly renders pan settings into audio even

When I render a virtual instrument with the setting “dry” (transfer channel settings), I have the issue that the actual pan-setting is rendered into the audio file (automation is sett to off!). The wave form of the audio is unbalanced, and even if I set the pan control to center, I hear it panned to left or right. That’s not intended and seems to be a bug. But maybe I’m missing something?

When I render a selected part of the same track, the pan setting is not rendered in (!), only if I render the whole track or if I select all the parts and render them in one steop.
I have a work-around for the problem: I glue all parts on the track together in one part, select it and then render it.

I can actually confirm this. Steps to reproduce:

  • create an Instrument track with two or more MIDI parts
  • set the channel panning to hard right
  • Do a Render in Place (either whole track or multiple selected MIDI parts) with the following settings: Mode: As separate Events, Processing: Dry

Result:
The first audio event is rendered correctly, the exact signal from the instrument. The following events are rendered with the pan settings of the track baked in.

Setting the Mode to “As One Event” works fine, as does “As block events”, but only if there isn’t a gap between parts, then all the following events are hard panned, too.
Does not happen e.g with channel volume or pre gain or other parameters, just with the panning.

Same in Cubase 12.0.40, actually. Does not depend on the VSTi.

Edit: If you set the output of the instrument to “No Bus”, everything renders correctly.

Thank you for confirming. I changed the title of the post as you suggested and added the tags “issue” and “Cubase 12”.

1 Like

It’s kind of mind boggling that no one ever noticed this before, I mean, I have used render in place on instruments before, although I probably mostly used the “as one event” setting. Still weird…

Only one user who can confirm the issue?

I’m mixing an album and this ruined several mixes, before I recognized the bug.

Thankfully fese had a solution for me: setting the out-bus of the VST-instruments to “none” . Thank you!

I also wonder why no one else will confirm this - it is easy to reproduce, I just did it again with an new 12.0.40 project and Retrologue and opened a support ticket at Steinberg with a reference to this Post.
I’d recommend that you open a ticket, too, don’t except any helpful answers, but just to let them know that not only one person has the problem.