UR22mkII stops the sound

Hi all,

I have got an UR22mkII sound card. Not so recently starts to stop sound when I am not using it from a phones output. For example, I am listening music on Spotify after an hour or so the sound gets cut. The only solution what I have found is that I open another sound source such as Youtube in a browser & start a random video which has sound & play with the volume knobs a bit. After couple of seconds the sound is coming back to Spotify & to the browser, as well.

Oddly, this issue never occured when I am using my headphones, therefore the phones output. Have you got any idea what could the issue & how can I tackle with?

I appreciate any helpful responses & thoughts! :slight_smile:

Cheers!

Maybe some energy management settings from the OS?

Hi @st10ss, thanks for your message & also sorry for the really late reply! I just noticed now that you have write to my question.

I do not think so, as I am using using High performance power plan & also unselected the power settings on USB. So they not suppoed to get idle. On the other hand it should affect then the phones output, shouldn’t it? Oddly, it is only from the normal output.

Are you running off a USB3 type port? If you have a USB2 port available on your system you could try that and compare if things improve.

Hi @wildschwein, I am using USB3 port. The device has also external power source. So I switched from USB power to DC.

1 Like

Has using external rather than bus power helped?

Yes, I thought it is a power issue, so I switched to it. But it does not help, as I mentioned when I am using the speakers (Output source) it still drops apporx. on an hourly basis. There is monpatter, though what I could have observe unfortunately.

Has it ever worked 100% fine? I’m wondering that you could try the previous version of the driver if the latest is causing issues.

There is other threads about similar problems here. See the last post for a fix:

More:

Hm… I am using the latest driver I suppose. That is a good question. Not sure whether it worked previously or not. :slight_smile:

I have seen these threads, but to me it feels like thebsolution is to replace the unit, I do not really like that idea to be honest, but if there is no other way, I might consider it.

I used to own one but sold it. I didn’t have any problems with it that I can recall. I upgraded to the UR824 so didn’t need it anymore. I would read through all the linked threads and see if you can isolate a fix. Rolling back the driver could be a thing to try.

I see, yeah. I used to have the old driver. Now I updated to the newer one which rolled out on the 24th of May. Let me see how it goes. Which version are you referring to, though?

1 Like

I just mean the last available Steinberg USB driver before the newest one in 2024. If the problems started after that you could go back a version. The last version before 2024 for Windows was 2020 and 2022 for Mac::

Alright, thank you! Let me try with that! :slight_smile:

1 Like

You can always go back to the newer one so no harm in trying.

Alright! :slight_smile:
I’m gonna try it! Thank you!