Distorted Screen/Cubase 10.5 pro

AMD fx 6300
16gb ram
Windows 10 fully updated
Nvidia 1070 gtx
500gb ssd

I just bought cubase. First of all, it was extremely difficult to get to work with all the licensing stuff. Anyway, it was working fine and started having this distorted Screen today for no reason. Only cubase does this. I can switch to any other program, play a game, and everything is fine. All drivers, all windows updates are already done. I was running cubase in 4k resolution just fine yesterday and for several days before that. Windows scaling is currently at 150% which is what it has always been at. The ONLY change is that I installed a Steinberg ur22mkii usb interface today. Got the latest driver, did the firmware update. I am very good with computers so feel free to talk tech. Thanks I’m advance. This is frustrating. I am kind of regretting buying cubase because studio one never had a single problem. I got cubase because I always wanted it, and from everything I have seen it seems to have superior features, I like the instruments, and I like how it looks, and I like the workflow. I included some screenshots, hopefully you can see them.

Hi and welcome,

This is not on Cubase side. It’s the graphic card driver issue. It has been discussed here on the forum few times already. Unfortunately I don’t remember the thread. Please search for it here on the forum.

OK, i am an idiot. I found someone had changed the image sharpening setting and it worked. For anyone else who has this problem, here is how i fixed it:

  1. If you have an NVIDIA video card, load up Geforce Experience (which you should already have installed)
  2. Click on the drivers tab, see the three dots next to DOWNLOAD? Click that.
  3. Download the NVIDIA studio drivers instead of the game ones. Dont worry, it has the exact same game performance.
  4. Once you have them installed, right click on the desktop and choose NVIDIA CONTROL PANEL.
  5. Click on MANAGE 3D SETTINGS.
  6. Turn off image sharpening (which appears to be on by default)

That should fix the problem. I am relieved. Now i just have to learn cubase by watching 900 hours of videos. No problem.

1 Like


Thanks for sharing.

Thank you !!! It has solved my problem :smiley:

Although I don’t see the sharpening image feature anymore, installing the studio version seemed to have solved my problem. On the GeForce forum there’s talk about how sharpening image has been replaced by image scaling. So that feature is off and I guess for some reason it works for the studio version of the driver.


Please, try to follow this thread.

No such setting for the Rtx series and 2023 Studio driver

1 Like


Good to know. But there must be something similar. The issue is on the graphic card driver.

Thanks. I tried this
But I don’t have “image sharpening” option in nvidia control panel. Neither with game-ready nor studio as selected driver.
I have “image scaling” and that is already set to off