Project View State

I recently updated my last working version which was Cubase 6.5 to Cubase 10. After spending a couple of days, I’m confident to say many of the old features are not available in the newest version. One of them that really bugs me right now, is the project view state doesn’t save and load anymore.
In the older version when you open a project, it would look exactly the way you saved it. it opened with the exact cursor position, zoom and ruler format.
But now it uses the same setting as the last opened project.
This is really a big deal. Some of us have projects with a large number of tracks and different ruler/time format.
Imagine you are working on a sound design project for a film or video. You set your ruler to timecode and zoom in all the way to an audio region, you save the project and open a music project. Now instead of Bar+Beat ruler format, you have timecode format with zoom setting and cursor position from the previous project.

I’ve been spending hours to find a workaround for this, no luck so far. There are a lot of similar posts for this concern

https://www.steinberg.net/forums/viewtopic.php?f=226&t=83429
https://www.steinberg.net/forums/viewtopic.php?f=252&t=112223
https://www.steinberg.net/forums/viewtopic.php?f=226&t=88635
https://www.steinberg.net/forums/viewtopic.php?f=253&t=108624
https://www.steinberg.net/forums/viewtopic.php?f=250&t=118400
https://www.steinberg.net/forums/viewtopic.php?f=283&t=147508


Steinberg, I beg you, Please fix this.


BTW under preferences, “Open projects in last used view” is set to never. (This option only works for windows layout )

bump

Yes, this one is bothering. Just working for so long with it (the current behaviour started in Cubase 7 I think) that I’m not used anymore to the great previous behaviour.

Cubase 10 is full of such little things that - from a user perspective - seem to be fixable pretty easy, make work much better, but never get fixed for obscure reasons.

It just offers a ton of great features compared to 6.5, so going back isn’t an option at all.