Phase drift and glitches with Transpose, Time stretching and AudioWarp/Quantize

Hi,

This is a long post, please read carefully.
I have done extensive testing trying to find out what could be the causes of the issue and possible workarounds.
I wish a Steinberg employee could take a closer look to this issue.

Transpose and Invert Phase from the Info Line and AudioWarp Quantize introduce phase drift.
There is a simple way to demonstrate the issue.
However, I highly recommend to use a spectrum analyzer like the new SuperVision. Put it on the output channel, select Spectrum Curve or Spectrogram and set the minimum level to -240 db, so you can visualize what is going on.

————————————————

PART 1 : Transpose and Invert Phase issue

  1. Import or record audio, duplicate the Event to another track (Alt + drag) and line them up.

  2. Select one Event, and on the Info Line, click on Invert Phase. Both tracks now cancel out.
    info line

  3. Select both tracks with Ctrl (Info Line values should change to orange), and while the audio is playing (but perfectly silent), start tweaking Transpose with the mouse wheel. You’ll instantly start hearing your track with unpleasant phasing.

  4. If you Transpose back to 0 while the audio is playing, it will once again cancel out perfectly.

  5. Now, while it’s still playing, Transpose again so you hear the phasing audio, but this time Stop playback, and press Play again, and you’ll immediately notice it’s silent, but it’s not ! Check your analyzer as it now introduces some bleeding, meaning that the tracks do not cancel out.

  6. If you try changing the Project Cursor’s position repeatedly while it is playing, or when you press Play from the Stop position, it will make a brief whistle-sounding noise around 500 Hz, as if very steep filters were applied. The frequency and level of this bleed depends on the audio material so you’ll get slightly different results with your own audio.
    If an Audio Event has a Fade, the whole clip will go out of phase and make phasing instead of the brief whistle-sounding noise.
    ( This thread from 2013 exposes the same issue : [issue] Glitch on clip start transposed w elastique!
    The user stated that when using Transpose, there were clicks at the start of each clip. If you duplicate the clips and invert the phase you’ll hear that the clicks transform into this exact noise instead, but only if you invert the phase from the Info Line - see step 8.
    More recent threads from 2021 also expose the issue : Fades on Musical Mode audio events trigger glitches and Cursed crackling noises? )

  7. Now, try toggling Invert Phase of one track repeatedly, and you’ll see that it introduces phasing, whether the phase is inverted or not.

  8. While the bleeding in step 5 is happening, disable Invert Phase from the Info Line and invert the phase in Channel Settings instead.
    invert phase in channel settings
    That will induce the phasing issue momentarily, but as soon as you move the Cursor to another place, the audio will now cancel out perfectly.

  9. When both tracks are in phase (disable any phase inversion), select them both, and Transpose while it’s playing. It will yield the same results as step 3 : phasing. If you move the Cursor anywhere or Stop and Play, both tracks will instantly be back into phase.

Related issue that I also want Steinberg to check out :

  1. Disk Cache spikes that happen when toggling Cycle (loop) (by the way, why would toggling Cycle even cause Disk Cache spikes ?) also trigger the step 6 noise, and strange enough, the Cursor needs to be before or within the Cycle selection range for it to happen. If the audio is playing after the loop range it won’t happen.

What do I conclude from the Transpose and Invert Phase issue testings :

  • There are internal errors when setting Transpose while audio is playing, which goes away by moving the Cursor or pressing Stop. As in step 9, applying the same processing to identical audio tracks should should immediately lead to identical results, but it does not.

  • The Invert Phase from the Info Line and Transpose don’t mix very well and produce some bleed. Using Invert Phase from Channel Settings instead cancels out the audio as it should.

  • I also have noticed that if you scroll Transpose fast enough when editing multiple Events at the same time, some Events will take a bit longer to finish transposing after releasing the mouse wheel, as if the processing was done in serial and not in parallel. I strongly believe this is the cause of clicks at the beginning of a clip, because Transpose takes a brief amount of time to initiate when the Event is read, causing the click. That kind of processing seems to be applied in real time, and that’s a problem. If having at least one clip with Transpose in the whole project, automatically adding some lookahead for pre-processing would kinda fix the issue.

  • Fine-Tune internal values should be updated as well. +1 is much closer to 0 than -1 . Smaller inconsistencies like that should never happen as of a professional audio workstation. I think this could be fixed fairly easily…

————————————————

PART 2 : Time Stretch

Time stretching behaves exactly the same way as Transpose.
Starting at Part 1 - Step 2 select the third option on Selection Tool (arrow with clock)
stretch tool
Select both events and modify their length a bit.
You can experiment with any steps in Part 1 (just replace “transpose” with “changing the events length”)

————————————————

PART 3 : AudioWarp / Quantize issue

  1. Import or record audio, duplicate the event to another track (Alt + drag) and line them up.

  2. Select one event, and on the Info Line, click on Invert Phase. Both tracks now cancel out.

  3. For one of the event, open the Quantize Panel, make sure AudioWarp is selected, and click Quantize.
    quantize panel
    Now click Reset Quantize. The event should be reset to its original state, as you would expect by clicking this button. But, from now on upon playback, it will start to introduce a slow phasing. It’s completely random, you can have a very low bleed for several seconds (-180 dB) and all of a sudden volume starts ramping up on its own and you get the phasing effect. Clicking the Reset button seem to stop the phasing but it will come back several seconds later. You can force the phasing by moving the Cursor. Additionally, unlike Part 1 - step 8, using Invert Phase from Channel Settings does not fix the issue.

  4. Using Transpose at the same time makes the phasing continuous, and there is no workaround.

  5. Once you hit the Reset button for the first time, it will irretrievably cause the phase issue on that audio Event. Even if you save the project, close Cubase entirely, and reopen the project, the phasing issue will still be there. The only way to revert this glitch is to Undo the Quantize action, with Ctrl-Z or by opening the History. By default, the number of Undo you can make is set to infinite, but if you put a lower custom value, you can easily lock up your audio in that glitched state.

Update April 2nd :
I have narrowed it down even more :

  1. The Reset button resets the waveform / hitpoints to their original position, but the AudioWarp markers aren’t removed. And that is the problem.

  2. Starting clean at Step 2, select the Free Warp tool, and add one marker at any place on one event. Be careful not to move the marker in the process, just click once without moving your mouse, this should not stretch the waveform. This results in the same issue as Step 3. With only one marker you may just have an audible bleed, if you add a few more markers it should go full phasing.

What do I conclude from the AudioWarp Quantize issue testings :

  • If an audio Event has at least one AudioWarp marker in it, and this marker hasn’t been displaced and no stretching is occurring, this Event will go out of phase. This just baffles me.

————————————————

ALGORITHMS

  • Transpose

    • Happens with every algorithm except Tape and Standard - Solo. If you change to one of the latter during playback, the phase issue will stop occuring right away (because Transpose is not compatible with Tape and won’t be processed)
  • Time stretch

    • Only happens with Time and Pitch algorithms.
    • If you change to Tape during playback, there will just be some audible bleed, which will completely go away if you move the cursor or stop/start.
    • Changing to a Standard algorithm during playback will (very) occasionally show a very low bleed on the spectrogram for a brief moment apart from the initial click.
  • AudioWarp

    • Happens with every algorithms except Standard - Solo.

————————————————

That’s all I could gather for now.
That would be fantastic if other users could try recreating the issue and post the results here.

Have a nice day,

Louis

6 Likes
    • I’m currently rewriting the topic cleaner

Very well written post, thank you.
I will check these phase issues out on my system with v10.5, 11 and 12 and report back.
Hopefully a Steinberg rep will chime in eventually.

1 Like

Has this ever been recognised or discounted by the Steinberg team?

1 Like

I wish. I just used the voting feature to give this a vote, perhaps if others do the same it will put this onto the Steinberg teams’ radar!

1 Like

Updated AudioWarp section.
Added Time Stretch issue.
Added Algorithm details.

Thank you @Timo00 for using a vote.

Here another user reporting same issue. I conclude I just can´t always use transposing… it´s a broken feature. I used the vote here too. Lets make this problem visible.

1 Like

Thank you @CdS-Etermax for using a vote, let’s keep those votes coming to get this fixed :slight_smile:

Just to remove any confusion, I am aware that doing so on normal audio causes audible clicks, because it starts and stops playing from the middle of the waveform.
The thing here is that it is not supposed to do that because the phase inversion is supposed to cancel out everything.

If I could vote twice, I would.

nuendo 12 same stuff. very sad.